HTTP 400 with version2.1.5 and github actions (Token-problem?)

My repository is PSA Prizes. The coverage function in the noxfile.py runs the necessary commands for codecov and should interact with my coverage-gh-workflow.

I used the same structure with success in another repo 3 months ago.

However, I now get the HTTP error in the new project as shown in the attached screenshot.
I am not sure, what causes the problem but I suspect that there is a issue concerning the passing of the secret token. (I also get a similar error when trying to release the package on PyPI.)

Yet, I quadruple-checked the token values and did not find an error.

Hi @tostenzel, thanks for this. We recently pushed out 2.1.6 that fixes the issue. Let me know if that works for you.

The update works fine! Thanks for your quick reply - on a sunday! Good job! :slightly_smiling_face:

Of course! Glad that the patch worked!