Bitrise upload step fails

Please search for similar issues before creating a ticket.
All fields below are required.


Bitrise Codecov step can’t find test coverage files

Codecov Output

  Codecov report uploader 0.1.17
[2022-02-23T13:10:22.549Z] ['info'] => Project root located at: /bitrise/src/[private]/build/reports/jacoco
[2022-02-23T13:10:22.549Z] ['info'] ->  Token found by environment variables
[2022-02-23T13:10:22.550Z] ['verbose'] Start of network processing...
[2022-02-23T13:10:22.550Z] ['verbose'] Searching for files in /bitrise/src/[private]/build/reports/jacoco
[2022-02-23T13:10:22.559Z] ['info'] Searching for coverage files...
[2022-02-23T13:10:22.572Z] ['verbose'] Preparing to clean the following coverage paths: jacocoUnitTestReport.xml
[2022-02-23T13:10:22.573Z] ['error'] There was an error running the uploader: Error while cleaning paths. No paths matched existing files!
[2022-02-23T13:10:22.573Z] ['verbose'] The error stack is: Error: Error while cleaning paths. No paths matched existing files!
    at cleanCoverageFilePaths (/snapshot/repo/dist/src/helpers/files.js)
    at main (/snapshot/repo/dist/src/index.js)
    at processTicksAndRejections (node:internal/process/task_queues:96:5)
[2022-02-23T13:10:22.574Z] ['verbose'] End of uploader: 26 milliseconds

Expected Results

Upload completes with no errors

Actual Results

No files found to upload

Additional Information

I’ve tried different additional parameters, none of which worked. Currently additional parameters are defined as follows:

-C $BITRISE_GIT_COMMIT -R $BITRISE_SOURCE_DIR/[private]/build/reports/jacoco -f jacocoUnitTestReport.xml -v

How do I point Codecov to upload a file called jacocoUnitTestReport.xml located in /bitrise/src/[private]/build/reports/jacoco directory?

@serhuz, have you confirmed the file exists there? If it’s there, what happens if you remove the -f [filename] from arguments?