Cannot exclude tracking target files from "Other files ignored by Codecov"


We started to use CodeCov for our Android-Library repository.
The root of repository is like following:

repo’s root

      ├ Android-Studio-Project
          ├ library
          ├ example app
      ├ Document
      ├ Some script
      ├ etc

Of course all coverage targets and tests are under “Android-Studio-Project”.
And coverage report are generated by Jacoco.

We uploaded coverage report, however all coverage tracking target are ignored by Codecov.
And NO settings are found for this problem.


Private repository


NO trying from CI/CD yet.
Only trying from local device.


bash <(curl -s -f Android-Studio-Project/library/build/reports/jacoco/jacocoMergedReport/jacocoMergedReport.xml

Expected behavior: [What you expect to happen]

  • Product codes are not included into ignored list by CodeCov.
  • Or exclude ignored list manually.

Actual behavior: [What actually happens]

  • All Product files ignored by Codecov.

Flakiness? [Does this happen all the time or only sometimes?]

  • always

Hi @fan-w-suzuki, can you DM me your codecov.yml, Codecov output, and a SHA please?

Hi @tom, thank you for replying.

Least I tried it default .yml and another custom one that fixes path and ignore list, the result is same.
Is is neccessary codecov.yml?

And what does “Codecov output” mean ?
I can found only SHA, branch name, parent SHA.

Hi @fan-w-suzuk, let me make sure I’m understanding correctly, we are ignoring files that you want to be tracked? Yes, a SHA would be extremely useful to help here.

Hi @tom,

we are ignoring files that you want to be tracked?

Yes, I would like to disable auto ignoring our tracking target file.

And how to send DM?
I could found a reply button however cannot find sending DM menu.

Hi @fan-w-suzuki, you should be able to click my name and see a button to Message me. Let me know if that doesn’t work.

Hi @tom,

Thank you for describing.
I’ve sent SHA via DM.

1 Like