Codecov results in "unusable report" when certain files are uploaded

Before submitting a topic, please confirm the following

I have searched for similar issues before creating this topic.
I have verified that my repository is using the Codecov GitHub app, if using GitHub
I have validated my codecov.yaml configuration file.
I have filled out the below sections to the best of my ability.
I understand that the community boards are a free, best-effort tool. While we hope to have someone on the Codecov team resolve your problem quickly, this is not always possible.


When uploading coverage reports for a module (core) in our repo while having a duplicate of that module in another directory (release/core), Codecov results declares that report unusable.


A link to the CI/CD run.

Codecov Output

Please provide the full output of running the uploader on your CI/CD. This will typically have the Codecov logo as ASCII.

==> linux OS detected
==> SHASUM file signed by key id 806bb28aed779869
==> Uploader SHASUM verified (e6aa8429d6ff91eddc7eced927e6ec936364a88fe755eed28b1f627a6499980d  codecov)
==> Running version latest
==> Running version v0.6.3
/home/runner/work/_actions/codecov/codecov-action/v3/dist/codecov -n  -Q github-action-3.1.4 -Z -C 3f55bc87446b999f6a5771cc075315c92fa57731
[2023-10-11T10:20:47.336Z] ['info'] 
     _____          _
    / ____|        | |
   | |     ___   __| | ___  ___ _____   __
   | |    / _ \ / _` |/ _ \/ __/ _ \ \ / /
   | |___| (_) | (_| |  __/ (_| (_) \ V /
    \_____\___/ \__,_|\___|\___\___/ \_/

  Codecov report uploader 0.6.3
[2023-10-11T10:20:47.344Z] ['info'] => Project root located at: /home/runner/work/expediagroup-java-sdk/expediagroup-java-sdk
[2023-10-11T10:20:47.347Z] ['info'] ->  Token found by environment variables
[2023-10-11T10:20:47.362Z] ['info'] Searching for coverage files...
[2023-10-11T10:20:47.591Z] ['info'] Warning: Some files located via search were excluded from upload.
[2023-10-11T10:20:47.591Z] ['info'] If Codecov did not locate your files, please review
[2023-10-11T10:20:47.592Z] ['info'] => Found 1 possible coverage files:
[2023-10-11T10:20:47.592Z] ['info'] Processing /home/runner/work/expediagroup-java-sdk/expediagroup-java-sdk/core/target/jacoco/jacoco.xml...
[2023-10-11T10:20:47.602Z] ['info'] Using manual override from args.
[2023-10-11T10:20:47.602Z] ['info'] Detected GitHub Actions as the CI provider.
[2023-10-11T10:20:47.827Z] ['info'] Pinging Codecov:*******&branch=osama-salman99%2Fcodecov-test&build=6481168187&
[2023-10-11T10:20:47.949Z] ['info']
[2023-10-11T10:20:47.950Z] ['info'] Uploading...
[2023-10-11T10:20:48.176Z] ['info'] {"status":"processing","resultURL":""}

Expected Results

Report processing succeeds and coverage passes.

Actual Results

Report is marked as “unusable report”
Tried cases in detail:

  1. Upload coverage report for core without the duplicate: Codecov succeeds. (Uploading core without release/core)
  2. Upload coverage report for core with the duplicate missing one file: Codecov succeeds. (Uploading both core and release/core, however removing one file from release/core so that they’re not identical)
  3. Upload coverage report for core with the duplicate: “unusable report”.
  4. Upload coverage report for core with the duplicate and adding an ignore config in codecov.yml as shown below: “unusable report”.


        # basic
        target: auto
        threshold: 0%
  - "release"

We have tried many different variations of ignore including:
but none of them seem to actually ignore the “release” directory.

Note: The actual path to the duplicate ‘core’ is “release/{dir1}/{dir2}/{dir3}/{dir4}/{dir5}/{dir6}/{dir7}/core”, however I use “release/core” in this topic for simplicity.

Additional Information

Commit SHA: 3f55bc87446b999f6a5771cc075315c92fa57731

@osama-salman99 sorry about the delay here. As the community boards are soon to be set to read-only, would you mind copying this and creating a new issue in our feedback repo?