Codecov started showing 'There was an error processing coverage reports' since today, no changes on our side


As can be seen from our project commits list, less than a day ago codecov started reporting errors. There have been no changes in codecov upload on our side. Build logs show no errors: reports are uploaded correctly.
For build we are using maven and jacoco, codecov is called from github actions.



Github actions



Commit SHAs

All recent commits. For example, 5354cb5150e4b890ba2439959b5897a719fed2c6

Codecov YAML

        threshold: 2%

Codecov Output

==> Reading reports
    + ./diktat-common/target/site/jacoco/jacoco.xml bytes=22370
    + ./diktat-rules/target/site/jacoco/jacoco.xml bytes=446745
==> Appending adjustments
    + Found adjustments
==> Gzipping contents
==> Uploading reports
    query: branch=dependabot%2Fmaven%2Forg.jacoco-jacoco-maven-plugin-0.8.6&commit=487060567379249cb6d54994ea0814e7235a1634&build=266801307&,n,F,Z
->  Pinging Codecov,n,F,Z
->  Uploading to
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed

  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
100 51098    0     0  100 51098      0  42369  0:00:01  0:00:01 --:--:-- 42369
100 51098    0     0  100 51098      0  41075  0:00:01  0:00:01 --:--:-- 41075
    -> View reports at

Steps to Reproduce

Currently any new commits to any branch are getting this behavior.

Expected behavior: Code coverage reports are correctly handled on codecov, data is reported to github.

Actual behavior: Codecov github check is stuck on waiting, codecov uploader doesn’t report any issues. On message is ‘There was an error processing coverage reports’.

Flakiness? Happens all the time since at least commit ef18316e3d1567bcf8eea54193ea58abd89c5c76 (

Additional Information

Switching report expiration off doesn’t seem to change anything.

Hi @petertrr, I have started to see the same error since early morning.

I submitted another issue an hour ago. Let’s wait for an explanation from the support team.

@jpaya17, FYI, in our project the issue seems to be resolved now.
Edit: nope, it was working for some 40 minutes and then back to described behavior.

1 Like

Hi all, we’re taking a look to see what might have happened here, thanks for your patience.

1 Like

I have started to see the same error since yesterday too

We are seeing the exact the same issue but only on 1/3 of our repos.

same here. xxxxxxxxx

Hi @petertrr, @jpaya17, @JakeRoh, @michaelst, @adrian-hc we had an issue here. Would you be able to see if this is still happening?

since about 2 hrs ago i see all successful reports. lgtm!

1 Like

@tom It’s working fine again! Very much appreciated to the team! :slight_smile:

1 Like

@tom Yes, looks good now! Kudos to the team for a quick fix!

1 Like