Error with reports since using github actions


Codecov reports were fine using bash cmd + Travis CI

Now unable to get any reporting:

  • Switched to github actions provided by codecov: No reports available (it seems the upload was successful)

  • Tried a custom github step using the bash cmd: Report is uploaded successfully, but nothing is available in the UI

Commit SHAs

Last commit: 807c737ebaa58ab2bd48e6e94cb2cd757be8f8fb
First commit where the report erroed: 0b65a277cfb519acd95c2761f7e33108c5ef651f


CI/CD or Build URL

Github action stdout using codecov action:

Gihub action stdout using custom step with codecov bash:


github codecov-action:
Bash: bash <(curl -s

Codecov Output

I cannot submit the output as “new user in the community cannot post more than 10 links”

Expected Results

A report available & metrics

Actual Results

Error 500 on the report link & “no report uploaded” on the codecov pulls list

Additional Information

Was working fine on Travis CI (.org & .com)

Did you fix anything ? one of my build randomly worked.

@ludofleury, no we haven’t yet made a change. However, would you be able to to link to the one that worked for you?

Actually no, false posittive, all the build are failing.
Is it a known issue about codecov & github actions? @tom?

@ludofleury, I pushed a fix yesterday, would you mind linking to a build URL? I might have missed an edge case.


@ludofleury, you will need to run the GitHub Actions Checkout step in order for Codecov to work in this GitHub Actions workflow.

1 Like

Hurrah! Big up to the team! build fixed, thank you @tom for your efforts & support.

1 Like