I cannot see my repository in Codecov.io UI, but coverage is being reported and comments are being made on my PRs

We are using the Codecov Github App on GitHub, private repositories, I have admin access to them, I do not have admin access on Codecov org. I used the bash uploader to upload codecov reports, that is working and codecov is commenting on our PRs with coverage info. However, while the admin on our Codecov org can see the repository, I cannot. If I try to navigate to the URL directly I get a 404. I have tried using incognito, clearing cookies, logging out and back in, syncing teams list, syncing repos list. I can see right on the page that there are 4 repositories in the bottom left corner, but I only see 2 of them. My Codecov org admin and I haven’t been able to find any docs or any support issues anywhere else of someone having this issue.


Hi @audiolion

We mirror access from GitHub and check that access via API on all page loads, not sure why they would be failing.

Any errors in the dev console? Can you share your username so I can check out logs?

I don’t see any errors, seems like the server is responding with the 404 page and no JS is being executed to fetch anything.

My github username is audiolion

Appreciate you looking into this @drazisil !

I’ll check the logs for this request tomorrow, thanks.

1 Like

Hi @audiolion, thanks for the patience.

Feb 25, 2020 at 20:45:32.703 UTC

ERROR GitHub HTTP 404 {"body":"{\"message\":\"Not Found\",\"documentation_url\":\"https:\/\/developer.github.com\/v3\/repos\/commits\/#get-a-single-commit\"}","bot":"audiolion","commit":"1261a7f","endpoint":"\/repos\/levelsoftware\/level-api\/commits\/1261a7f1608290fccd8c5f66bd3b412f4623828d","event":"api","method":"GET","public":"n","rlr":"1582664154","rlx":"4790","rly":"5000","service":"gh","slug":"levelsoftware\/level-api"}

GitHub is very, very sure that you do not have access to this repo. If that’s not the case you may need to contact their support as we can only go by what the API says. I’ve added the timestamp in case that helps.

1 Like

I just checked and another service pulling git activity also cannot see them. What is crazy is I can access these through the github ui, in fact the level-agent repo I created myself. I will contact github support, thanks!

1 Like

I’m having the same issue: it’s loading a stale list of my repos. It’s actually showing repositories that I have been deleted completely (last time I used CodeCov was 2 years ago)

  • Tried uninstalling & adding the GitHub application
  • Deleted and re-created my codecov account
  • Tried in Firefox Dev Tools and Google Chrome using private window with no addons enabled.

It just hangs on “Syncing GitHub Teams” on the main screen, and “Syncing team repositories” on the repositories screen.

I finally went into Firefox about:config and changed security.csp.enable to false after seeing there are several content security policy errors. Then I was able to load the URI gh/patrickclery/dry-rails-react <— this was the only thing that worked.

Attn. Codecov Devs: I think there are some JavaScript methods that are being blocked by certain browsers

EDIT: I included a screenshot

@patrickclery thanks for additional context here, I’ve added to our issue tracker. This is an open issue on our current sprint and we are looking to fix once we find root cause.

1 Like

Hey forgot to say I solved this. The issue is my works org used my work email to invite me to the org, and while I was able to use the link to join, I had not linked that work email to my github account. By adding the email address on github everything came through!