Reports are queued for processing... Please review report with caution, it may change

Thanks for your response. I switched to the new uploader as well and yet the same issues . Also, I am on bitbucket cloud so I am using my bitbucket user as Team bot and have added my username in codecov.yml file. @tom

@s1mrankaur do you have a new commit SHA with the issue? I can dig into that one to see what is going wrong.

1 Like

@tom Sure, Here you go:

CommitId: 19b2124acb16006e195e0f22082add72f840cbee


     _____          _
    / ____|        | |
   | |     ___   __| | ___  ___ _____   __
   | |    / _ \ / _` |/ _ \/ __/ _ \ \ / /
   | |___| (_) | (_| |  __/ (_| (_) \ V /
    \_____\___/ \__,_|\___|\___\___/ \_/

  Codecov report uploader 0.1.12
[2021-11-15T18:08:49.324Z] ['info'] => Project root located at: C:/Users/SIKAU/Downloads/vlncc-backend
[2021-11-15T18:08:49.327Z] ['info'] ->  Token found by arguments
[2021-11-15T18:08:49.456Z] ['info'] Searching for coverage files...
[2021-11-15T18:08:49.520Z] ['info'] => Found 3 possible coverage files:
  coverage/clover.xml
  coverage/coverage-final.json
  coverage/lcov.info
[2021-11-15T18:08:49.521Z] ['info'] Processing C:/Users/SIKAU/Downloads/vlncc-backend/coverage/clover.xml...
[2021-11-15T18:08:49.524Z] ['info'] Processing C:/Users/SIKAU/Downloads/vlncc-backend/coverage/coverage-final.json...
[2021-11-15T18:08:49.575Z] ['info'] Processing C:/Users/SIKAU/Downloads/vlncc-backend/coverage/lcov.info...
[2021-11-15T18:08:50.147Z] ['info'] Detected Local as the CI provider.
[2021-11-15T18:08:50.418Z] ['info'] Pinging Codecov: https://codecov.io/upload/v4?package=uploader-0.1.12&token=*******&branch=codecov_integration&build=&build_url=&commit=19b2124acb16006e195e0f22082add72f840cbee&job=&pr=&service=&slug=vimnet%2Fvlncc-backend&name=&tag=&flags=&parent=
[2021-11-15T18:08:50.815Z] ['info'] Uploading...
[2021-11-15T18:08:53.902Z] ['info'] {"status":"success","resultURL":"https://codecov.io/bitbucket/vimnet/vlncc-backend/commit/19b2124acb16006e195e0f22082add72f840cbee"}        
PS C:\Users\SIKAU\Downloads\vlncc-backend> ```

updated codecov.yml file:

codecov:

  bot: Simran

  max_report_age: false

  require_ci_to_pass: false

  notify:

    wait_for_ci: false

comment:

  behavior: default

  layout: reach, diff, flags, files

  require_base: false

  require_changes: false

  require_head: false

coverage:

  status:

    project:

      default:

        target: 80.0

        threshold: 1.0

Try 2:
I removed clover.xml from the coverage directory and uploaded the report again for the same commit. In that case- I get:

One thing to note here is that the “Impacted files” actually never load.

@tom

@tom Please let me know if I can furnish any more information. Also, I should point out that no pull-request comments get generated. Also, no pull requests show up in codecov either.

@s1mrankaur hmmm, the codecov.yml file you posted looks valid, but we are not seeing that. Did you update codecov.yml on the same branch/PR as the last commit you posted (codecov_integration)?

@tom Thanks for your response. I have not updated codecov.yml. If I clicked on view YML from the reports dashboard: I see

1 codecov:
2	  bot: Simran
3	  max_report_age: false
4	  notify:
5	    wait_for_ci: false
6	  require_ci_to_pass: false
7	comment:
8	  behavior: default
9	  layout: reach, diff, flags, files
10	  require_base: false
11	  require_changes: false
12	  require_head: false
13	  show_carryforward_flags: false
14	coverage:
15	  precision: 2
16	  range:
17	  - 70.0
18	  - 100.0
19	  round: down
20	  status:
21	    changes: false
22	    default_rules:
23	      flag_coverage_not_uploaded_behavior: include
24	    patch: true
25	    project:
26	      default:
27	        target: 80.0
28	        threshold: 1.0
29	github_checks:
30	  annotations: true

@s1mrankaur I don’t think you’ve completed team bot setup

Please follow these steps to select a Codecov Bot.

Choose an existing user account, or create a new bot account.
Login with this account into Codecov.
Grant private repository access for GitHub users.
Set the bot in the Team Yaml by navigating to /account/PROVIDER/OWNER/yaml.
Type in the new username in the yaml as seen below.
Click Save.
Run a CI and upload coverage to Codecov to confirm that the new setup works.

@tom

Thanks for your response. Please find my response below:

  1. I chose an existing BitBucket user account - Simran
  2. Logged in Codecov using Simran through Bitbucket cloud
  3. ‘Simran’ user already has access to the repositories. (In fact is an admin)
  4. Set the bot in the Team Yaml by navigating to /account/PROVIDER/OWNER/YAML - Does adding
codecov:
	  bot: Simran

to codecov.yml in our project source not work?

I have now added

codecov:
	  bot: Simran

to Global YAML file under our project as well.

  1. Also, even if the code-coverage report is submitted through CI (Codebuild) - I always see CI failed in codecov. Attached snapshot.

  1. Why do the Impacted files never load?

  2. Why does it say unable find commit for a lot of those? Attached snapshot

    - Checked- It starts showing the commit name once I click on the commitId.

Hi @tom I’d love to be able to resolve this as integration with pull requests is kind of our primary reason to evaluate codecov. Can you help resolve this, please?

@s1mrankaur I don’t see any record of Simran, are you sure that the user has logged into Codecov?

Do you see “vlncc” instead ? @tom

In CodeCov, I see the user in the users list as the snapshot attached. Should I be using vlncc instead of Simran?

codecov9

Alternatively, can you share the records that you can see or the usernames that can be used for team bot? We currently have 4 active users on CodeCov that login through bitbucket cloud.

or do you see sk_hellburner or VLNCC? I just logged into codecov again through bitbucket cloud and it started showing as in the snapshot

Also, @tom I just change the team bot name to vlncc as well. I still don’t see a pull request comment or the pull request itself in codecov.

Here’s the commit Id: 483e3fd6b5ce569135f898bc66f39396d9b0a415

Code report link: https://codecov.io/bitbucket/vimnet/vlncc-backend/commit/483e3fd6b5ce569135f898bc66f39396d9b0a415

@s1mrankaur yes, it should be their bitbucket username. The user will need to login with private scope here

Alternatively, can you share the records that you can see or the usernames that can be used for team bot? We currently have 4 active users on CodeCov that login through bitbucket cloud.

I cannot do that for security reasons.

@tom For my own user which is the admin on both bitbucket and codecov:

It can either be
→ Simran (What I see on Bitbucket cloud for my commits)
→ vlncc (What I see on CodeCov for my commits)
→ sk_hellburner (What I see on Atlassian )

Simran is not what shows up on codecov anywhere and I have tried with both Simran and vlncc , yet fail to see the pull requests in codecov. If you need me to privately share any information to address security concerns I can do that. I’d really like for this to be resolved as it’s completely blocking us from evaluating the tool for our workflow.

Also, under current repository settings on codecov, it shows as attached in the snapshot
codecov 10
@tom

@s1mrankaur

I’ve manually corrected this, can you please test with a fresh commit?

@drazisil Thanks for your response. I checked. The correct codecov.yml now shows up which is GREAT. I also started seeing the pull request created this morning under pull requests TAB. That is AWESOME. I am so glad it was addressed. Attached snapshot:

Do you mind sharing what the issue was? In case it happens again- I’d have an idea.

Much as I’d love to, it boils down to, “team bot isn’t getting set from the global YAML for unknown reasons and I manually set it in the database”

I don’t think that’s anything you could affect on your side.

1 Like

Thanks for sharing. @drazisil

1 Like