There was an error processing coverage reports. (like many others)

Description

In my CI I run pytest --cov "src/repr_utils" --cov-report term --cov-report xml and the coverage.xml file looks correct in my eyes. Yet I still get the error “There was an error processing coverage reports.” (see the image below). Running bash <(curl -s https://codecov.io/bash) -Z also provides no errors. My main issue is that since the error provides no relevant information to what is actually going wrong I have not clue what I should do to solve it.

Repository

Additional Information

So far I have tried the following to solve the issue:

  1. multiple variations of generating to XML cov-report
  2. Both the python codecov module aswell as the bash script
  3. Variations of path fixes in the yaml file ("I can’t however exclude that this isn’t where it is going wrong since I can’t find in the docs what codecov actually expects as input).

You can look at an example of the XML file here you can find it under the “upload codecov data” step.

Any help towards solving this would be much appreciated.

HI @Luttik, looks like you were able to get coverage (and at 100%!)