400 error when uploading coverage for monorepo

Hi,

I have a problem very similar to this comment (Action recently started giving 400's · Issue #220 · codecov/codecov-action · GitHub).

I recently migrated my open source tool, UpscalerJS, to a monorepo (multiple packages under the /packages directory). Coverage stopped working.

My codecov.yaml is here: UpscalerJS/codecov.yml at master · thekevinscott/UpscalerJS · GitHub

I’ve tried to integrate the codecov Github action; that is done here:

However, coverage fails to upload. Here is a verbose example:

I get back the error Invalid request parameters and a 400 request when trying to upload, and I have no idea why.

Would appreciate any feedback or guidance. I’m not sure if I should be using the GitHub Action, or if there’s a way to make the monorepo work with a simple codecov.yml

@thekevinscott I’ll make a patch to the GitHub Action to handle this properly.

1 Like

Excellent, thanks @tom ! Looking forward to it.

Hi @thekevinscott I made a fix in 1.3.2. Would you be able to try it and see if you’re still getting an error?

1 Like

Apologies for the long response time, @tom. I just tried again and this appeared to fix the bug and coverage is uploading again. Thanks for your help!

1 Like