Cannot disable codecov/patch check?

What do you mean? Move enabled: yes in project?

# configuration related to pull request comments
comment: no # do not comment PR with the result

  range: 50..90 # coverage lower than 50 is red, higher than 90 green, between color code

    project: # settings affecting project coverage
        target: auto # auto % coverage target
        threshold: 5%  # allow for 5% reduction of coverage without failing

    # do not run coverage on patch nor changes
    patch: false

Try this :slight_smile:

I am going to try this last option now. Removing the enabled: yes did not work either, in case it helps, here is the sha c5ec4a094182414cc99231f696d3d3a8b372a68f.

In around 10-15 minutes I will reply again, hopefully saying it works, otherwise with a new sha.

Thanks for your patience.

1 Like

Unfortunately it did not work. Here is the sha be4102955978d03da4e7d9451d16154acaa65f6b

Could it be due to some other misconfiguration outside the yaml file?

This YAML is now valid. :tada:

You still received the patch status?

1 Like

Is still edits the comment:

And shows both project and patch check :confused:

I met the same issue. yaml file is valid, but codecov/patch is still there.

Can you please make sure your file is named codecov.yml, @gpengzhi and @OriolAbril ?

(no period)

1 Like

It works! Thanks a lot!

1 Like

Using codecov.yml instead of .codecov.yml solved the problem, thanks a lot.

It would be great if you could update the docs or explain how would we update them if it were possible. There are various references in the docs to .codecov.yml and there is a question about this in the FAQs where it is clearly said the initial dot in the name should not affect.


There should be a suggest edits link at the top right of every docs page, i will go though and adjust any references i find on Monday.

Glad that fixed it for you.

1 Like

It looks like our old code has a bug where it will find a file that starts with a dot, but the new code fixes this. Since the new code will be fully deployed soon, I’m going to hold off on docs edits for now. I’ll keep an eye on the issue and see how many folks hit it.

Edit: I’ve updated all docs pages to clarify that the file needs to be named codecov.yml (no period)

1 Like

I also have problems turning off the patch status in What’s the current state of this? Is the documentation up to date? Does .codecov.yml work reliably?

Hi @karlb

The file needs to be named codecov.yml (no period). I believe I’ve updated the docs everywhere for this, please let me know if I missed one.

My commit above was written backwards, let me correct.


Sorry, I misunderstood your ask. Your YAML is being ignored because your flags section is invalid. It should be:

  - unit
  - integration

Thanks for the feedback @drazisil!

The yml properly validates now and has been renamed to codecov.yml. Unfortunately, I still get the “codecov/patch” status:

I tried to turn it off as described in

Hi @karlb

It’s still failing validation internally, I left a comment on the PR.


As I suspected, this is a bug in the legacy version of our notify task, that is fixed in in our new version. Since everyone will be on the new version in the next week or two, we have opted not to fix the old version. Once all your jobs are running though the new notify task (it’s a percentage currently) the patch status will go away.

Hello @drazisil ,
We have the same issue.
File is named codecov.yml and the “comment” setting is set to false.

Here is the codecov.yml content:

  branch: dev

# Disable PR comments
comment: false

    project: false
        threshold: 80%

Last commit sha is: 45c05f28d70ea8306d9bc64945a86dbd37ce924d


The codecov/patch status check is not the same as the PR comment. I see you still have the status check enabled, per the codecov.yml you posted.