Codecov cannot sync repos

Please search for similar issues before creating a ticket.
All fields below are required.


Plain and simple - cannot sync any of my repos from github as it’s supposed to do when I login with github.

I tried to re-sync.
I tried to revoke access from github’s oauth and re-login (like mentioned on codecov’s site)
There should be no org issue as it’s my personal project and repo.
I’m just a free github user not part of any org yet and all my repos are public.
I even went to settings on codecov, erased my account, deleted browser data for last 7 days, deleted localstorage, revoked oauth access from github and then tried it all over again. Does. Not. Sync.

Commit SHAs

Repos aren’t even synced. No commit SHA



CI/CD or Build URL

Not a build issue - no buld URL.


trying to use circleCI’s orb but can’t because the repos have to be synced first.

Codecov Output

No CICD pipeline run, therefore no codecov output.

Expected Results

I’m expecting the repos to at least sync first before I can add a project.

Actual Results

Repos not synced.

Additional Information

Edit 1: I switched to coveralls and all my repos got syned in a second, but I’m having a different set of issues there. Also, there does not seem to be any issue with my circleci pipeline (which is the only thing not giving me issues), all tests in my code and checks on github are passing with flying colors.

Try to click “Not yet setup” and see if your repos are there.

1 Like

Oh my god. I just realized the true extent of my stupidity.

Thanks so much!

1 Like