Codecov/patch keep failing and failing and failing, plz help

Before submitting a topic, please confirm the following

I have searched for similar issues before creating this topic.
I have verified that my repository is using the Codecov GitHub app, if using GitHub
I have validated my codecov.yaml configuration file.
I have filled out the below sections to the best of my ability.


Description of the issue

I am trying to solve the issue with codecov/patch adding annotations and failing because line X is not covered by tests.
It never happened before and appeared around ~2 weeks ago.
How could I stop it from happening?
I tried to add .codecov.yml to the root of the project

I don’t know why it’s failing or how to solve it and the documentation do not provide proper solution for this.


Please provide a link to the CI/CD run.

Codecov Output

Please provide the full output of running the uploader on your CI/CD. This will typically have the Codecov logo as ASCII.

Expected Results

Make sure that it’s not marking PR’s as failures when they’re clearly passing the tests

Actual Results

Codecov/patch failing

Additional Information

We’re not using the Codecov github app because it never worked for us. We combine the coverage results and upload them manually.

@Fewwy you do one of the following

  1. Set patch to informational
        informational: true
  1. Set target to 0 (auto doesn’t really make sense)
      target: 0