Confusion regarding team bot setup


I got confused regarding the usage of team bots.
I read the documentation here:
I tried to setup my team yml by adding only two lines to define the bot:

  bot: herf

The bot’s username is my username both on bitbucket and on codecov, I hoped it would work, but it did not.
The web page says, my current bot is still None.
According to the doc I need to log in with the bot account. But since I can only log in with bitbucket credentials, that means I need to have a separate bitbucket account which has access to my repo in question. Is that right?
Some clarification would be helpful, I do not want to create an unnecessary bitbucket account without knowing it would work.

Thanks for the help in advance!

Also, I realized things were kind of OK, until 2 April, codecov was posting coverage results to bitbucket for every commit. Although the commit author was always unknown in codecov.
Then I changed the config yaml, and since then nothing works. Codecov posts nothing to bitbucket, but can figure out the author of the commits - although profile pictures are broken. Also, since I changed the config yaml, I got the “Waiting for CI to complete” message for every commit. I guess that is the root cause for codecov not updating my commits in bitbucket.

Hey @herf, sorry to hear about the really bumpy start to your usage of Codecov. We aspire for much smoother.

Can you link to the repo in question so we can see on our side too?

Some points: yes, your bot account will need to log in, in can be your account though. Some people prefer to have a non-personified bot account / new bitbucket account so no individual is on the hook to post comments and receive notifications.



Thanks for looking into the issue (?) :slight_smile:
Here is my repo on codecov:

And here it is on bitbucket:
There is a commit on 2020-03-04 (sha:
) which is the last one with report from codecov.
I hope it helps!


Hi @herf, just an update that we are digging into this issue to see why it might be happening.

Hi @herf, I’m still digging into this and trying to get a solution. Right now, it looks like there might be a permissions error. Would you try logging out of, deleting all your cookies for the site, and logging back in? I want to make sure it’s not a stale oauth token issue.


Sorry for the late reply.
I tried what you said, and also tried to login in privacy mode in google chrome.
I am not sure what else is needed.
I noticed that every time I log in, I need to grant access to my bitbucket account. Maybe that is related to the issue.
I checked the application authorizations in bitbucket and codecov is listed there, with today as the latest access date.
Please note, that I have set up 2FA on bitbucket. Sometimes I got issues because of that, and had to set up app passwords to make it work. Can it be the root cause?

Hi @herf, thanks for your patience here. We’ve been noticing an issue with login over the past few days and are working on a fix.

I noticed two things, that your team-bot is actually not set as a team yaml. You can set that here as

  bot: herf

It looks like this was once set, but was removed 2 months ago.

You can also add that line to a codecov.yml file in that repository if you want to see it work. Let me know if either of those solutions works for you.


I changed the settings in codecov and also added the yaml file to the repository.
I see no changes, the settings page still says my bot is None, and codecov does not push the results to bitbucket.

Hi @herf, apologies on this. The reason the yaml didn’t work is because we are currently experiencing a different issue here. When this is resolved, I suggest pushing a new commit where I can check that the yaml file gets pulled in. Again, thank you for your patience here.

Hi @herf, the issue has been fixed. Would you mind pushing another commit with the yaml change?

No luck, I am afraid.
Did another dummy commit - the yaml file is already in the repo -, but nothing has changed.
The settings page still says my bot is None, and codecov did not push the reports back to bitbucket.
Also it says it is waiting for the CI to complete…
I tried to log in to codecov from ignognito mode but that did not help either.

Hi @herf, I think we’ve found the root cause and are working on a fix. Thanks for your patience here.

Hi @herf, just an update, we are still working on the fix, but plan to have it pushed today.

Hi @herf, apologies here, we are still investigating why this is still happening.

Hi @herf, just an update that we are still looking into this. Thanks for your patience here.

Hi @herf, I haven’t forgotten about this issue, thanks for your patience as we work towards a fix.

Hi @tom, any updates on this issue?

Hi @benedictkhoo, thanks for checking in. We are hoping to get this fixed by the end of the year.

Hi all, we are still working on a fix here, thank you for your patience.