Informational mode: coverage not affected

Description

In informational mode, coverage is reported as " Coverage not affected" , see my struggle at https://github.com/doctrine/inflector/pull/167
I tried adding a big piece of uncovered code, and would expect something saying that the new code was not covered at all (but non blocking). Instead, it says “Coverage not affected”

Repository

CI/CD

Travis

Uploader

The bash uploader

Commit SHAs

9cb495e

Codecov YAML

comment: false
coverage:
  status:
    project:
      default:
        informational: true
    patch:
      default:
        informational: true

Codecov Output

  _____          _

 / ____|        | |

| |     ___   __| | ___  ___ _____   __

| |    / _ \ / _` |/ _ \/ __/ _ \ \ / /

| |___| (_) | (_| |  __/ (_| (_) \ V /

 \_____\___/ \__,_|\___|\___\___/ \_/

                              Bash-20200602-f809a24

==> Travis CI detected.

    project root: .

    Fixing merge commit SHA

    Yaml not found, that's ok! Learn more at http://docs.codecov.io/docs/codecov-yaml

==> Running gcov in . (disable via -X gcov)

==> Python coveragepy not found

==> Searching for coverage reports in:

    + .

    -> Found 1 reports

==> Detecting git/mercurial file structure

==> Appending build variables

    + TRAVIS_OS_NAME

    + 7.2

==> Reading reports

    + ./clover.xml bytes=83390

==> Appending adjustments

    https://docs.codecov.io/docs/fixing-reports

    + Found adjustments

==> Gzipping contents

==> Uploading reports

    url: https://codecov.io

    query: branch=2.0.x&commit=9cb495e7536c89b0a763c2f2889b5b5f9a4221e1&build=623.5&build_url=&name=&tag=&slug=doctrine%2Finflector&service=travis&flags=&pr=167&job=697794413

    -> Pinging Codecov

https://codecov.io/upload/v4?package=bash-20200602-f809a24&token=secret&branch=2.0.x&commit=9cb495e7536c89b0a763c2f2889b5b5f9a4221e1&build=623.5&build_url=&name=&tag=&slug=doctrine%2Finflector&service=travis&flags=&pr=167&job=697794413

    -> Uploading

    -> View reports at https://codecov.io/github/doctrine/inflector/commit/9cb495e7536c89b0a763c2f2889b5b5f9a4221e1

Additional information

In my struggle, we have added the Github App yesterday to the whole organization, and we have added a team YAML in informational mode.

Ahhh, hi @greg0ire. I think there was a strange permissions error going on (I recommend logging out, clearing cookie, and logging back in). Would you be able to rebuild the project one more time? I think I had fixed that permissions issue.

Hi @tom! Do you mean clearing cookies from Github, CodeCov or both? Also, what could cookies have to do with this? Surely it doesn’t depend on who triggers the build again, right?

I edited my post to add additional information that might help. Also, I notice that on a repository where there were already reports, and where the PR is based on a recent enough commit, things seem to behave normally: https://github.com/doctrine/dbal/pull/4074

EDIT: In doubt, I logged in from both websites, closed and reopened the PR, no dice. Tried amend and force push, no dice.

To make sure we are on the same page, I’m talking about this:

Screenshot_2020-06-13 Use CodeCov instead of Scrutinizer by greg0ire · Pull Request #167 · doctrine inflector

I’m not talking about the full fledge report, which seems to work just fine.

1 Like

Hi @greg0ire, sorry for the delay here. The reason you are seeing this is that there is no base report to compare against on these pull requests. You should expect to see patch coverage when a base commit has coverage.

Ok great, consider maybe changing the message to something less confusing, it might affect adoption if the first experience looks buggy. I must say that now that we have merged, things look gorgeous, so that would be a real shame! Thanks for your answer.

Thanks for the feedback here @greg0ire, and glad that everything is working perfectly! I’ll relay this to the product team so that we can look into making improvements here.