Looking for assistance with path fixing



after unsuccessfully trying to find the correct path for my repository, I give up. I am looking for help to figure out the correct path fix for my mono repository.

Description of the issue

The coverage report uploaded from the original repository only contains data for the application layer. The data for infrastructure, domain, and presentation layer is missing. When inspected locally the data is complete.

The issue is finding the correct path fix for my case. I have created a new repository and added one of the packages to the new repo. For this new repo the coverage report is uploaded without missing as expected. Due to the purpose of the original repository that contains multiple packages, I would like to make it work with the nested root.



GitHub Actions


Commit SHAs


Codecov YAML

  max_report_age: 24
    - '/::flutter_bloc/'

Codecov Output

It is easier to take a look at it inside the actions’ log:

Additional Information

Since the repository is public, the codecov.yml, the codecov output and more information can be found inside the repository’s logs etc.

I have tried to create a new repository and copied the flutter_bloc example in the new repository. The codecov action works as intended and the report is complete. Therefore I assume, that I need to fix the path since the original repository contains 2 different examples. This means, that the repository root is 1 level above the coverage report containing example.

Thank you for your time.

Hi @eddiesTime, just taking a quick look, the yaml is invalid because fixes needs to be at the root. Try

  max_report_age: 24

  - '/::flutter_bloc/'

Hi @tom, thank you for the quick response. I feel so stupid to have missed the correct indentation.

Unfortunately, it did not fix the issue with the missing data. Do you have another suggestion?

Hi @eddiesTime, I don’t think you need the first slash

  - '::flutter_block/'

Let me know if that works.

Hi @tom, it did not work with your latest suggestion.

With my original implementation without path fixing the root folder on my dashboard at codecov for the repository are as follows: flutter_bloc/lib/application

With the latest path fix of
- ‘::flutter_bloc/’

The root folder is changed to flutter_bloc/flutter_bloc/lib/application

In the standalone repository that I’ve created for the flutter_bloc example, the files have the root folder of lib, which contains all test data.

On a side note, I only have tests and a coverage report in the subdirectory flutter_bloc

Hi @eddiesTime, as you saw I messed around with getting path fixing to work here to no avail. I’m not worried about the package size because (1) we gzip the report before uploading to Codecov, thus the small size, and (2) it seems like the report when we receive it has coverage for other files that aren’t showing up.

I’m going to escalate to the product team to see why this might be happening.

Hi @tom,

thank you for the support. If any questions come up from you or the product team, don’t hesitate to contact me! :slight_smile:

1 Like

Hi @eddiesTime, I wanted you to be unblocked by this while we try to dig into a fix. You can see reports here which updates the coverage report like so. Let me know if this fixes your issue for now.

Hi @tom, please excuse me for the late reply! Don’t worry, I’ve been working on the duplicated repository where the project is in the root.

I have tried out your workaround. It works! All files are included in the test report.

Thank you very much! Keep up the good work :slight_smile:

Absolutely, I’m glad that it works for you!