No codecov comments on Merge Requests on gitlab


No codecov comment in Merge Requests on gitlab.

Commit SHAs



CI/CD or Build URL


Python uploader (I tried the new one but it failed, I will get back to it once the MR comments work).

Codecov Output

      _____          _
     / ____|        | |
    | |     ___   __| | ___  ___ _____   __
    | |    / _ \ / _  |/ _ \/ __/ _ \ \ / /
    | |___| (_) | (_| |  __/ (_| (_) \ V /
     \_____\___/ \____|\___|\___\___/ \_/
==> Detecting CI provider
    Gitlab CI Detected
==> Preparing upload
==> Processing gcov (disable by -X gcov)
==> Collecting reports
    Targeting specific files
    + py38-coverage.xml bytes=1111741
==> Uploading
    .query commit=fc7a3d4fe82f2627eb9b1d6fb524f8f8481ad13e&branch=add-codecov&token=<secret>&service=gitlab&build=1488855441&slug=AntoineD%2Fgemseo&yaml=codecov.yml&package=py2.1.11
    Gzipping contents..
    Compressed contents to 76998 bytes
    Pinging Codecov...
    Uploading to S3...
    Uploading to S3 took 0:00:00.466871

Expected Results

A codecov comment in this MR as described in Pull Request Comments.

Actual Results

No MR comment from codecov.

Additional Information

The CI has completed but the codecov web interface oforthis commit shows
Waiting for CI to complete. Please review report with caution, it may change.
Notifications are pending CI completion. Periodically Codecov will check the CI state, when complete notifications will be submitted. Push notifications now.

The bot is my account but the codecov web interface setting for this repo shows
Current Bot: None

On gitlab, I’ve searched for projects with working codecov comments in MR, I found none with recent (<6 months) MR!

@tom Would it be possible to move this topic to the Bug section please?

Hello, I have same issue that started on 7/6 and I noticed that the activity of Codecov · GitLab stopped on 5/6, could this be related?

Ah! Thanks for the info @konykon.

@AntoineD moved, I’ll take a look at what’s going on here.

@AntoineD would you be able to push a fresh commit to that MR?

@tom I just pushed a commit.

@AntoineD, yeah this does look like a permissions issue. Would you be able to log out of Codecov, delete all Codecov cookies, log back in again, and make another commit?

@tom, I logged out of, cleared the cookies from my browser, logged back in and pushed a new commit: still not luck.

I noticed that since yesterday the new commits are marked as Unable to find commit in Gitlab.

Got it, thanks @AntoineD. Our product team is taking a look into this.

Hi @tom, have you got some news from your product team?

Sorry @AntoineD I haven’t gotten word back. Still investigating the root cause.

This one’s related:

Has been an issue since start of June for us too. It looks like codecov stopped using the global gitlab account in favour of team bots, but the team bot config is broken.

Thanks @antonyoni, I’m wondering if there is a public gitlab project for which codecov works since June.

@tom Are there any update from your side ?

Not yet @AntoineD, this is in our product team’s queue. I’ll update here as I have updates. Sorry for the delay on this.

Hi @tom, are there any news from your product team?

@AntoineD I’m sorry, it’s been prioritized and our engineers are working on a fix.

@tom any updates on this? This is blocking me from pushing codecov to my team, as having the comments on merge requests is one of the most fundamental features I wanted to show. In my case it is a private repository, and no comment was posted to the MR.

NVM, that was caused by not having the team bot set.

1 Like

@JCMais If your project is public, would you mind to give its URL so I can have a look? (Up to now I have not found a gitlab project where codecov works)

@AntoineD, we pushed a fix for this, could you see if this is happening on new MRs?