Gitlab - codecov not posting comments in pr, team bot is missing

Before submitting a topic, please confirm the following

I have searched for similar issues before creating this topic.
I have verified that my repository is using the Codecov GitHub app, if using GitHub
I have validated my codecov.yaml configuration file.
I have filled out the below sections to the best of my ability.


gitlab CI team bot is missing


private repo, will attach logs

Codecov Output

Please provide the full output of running the uploader on your CI/CD. This will typically have the Codecov logo as ASCII.

$ wget
Connecting to (
saving to 'codecov'
codecov               44% |**************                  | 19.1M  0:00:01 ETA
codecov               87% |****************************    | 37.7M  0:00:00 ETA
codecov              100% |********************************| 42.9M  0:00:00 ETA
'codecov' saved
$ chmod +x codecov
$ ./codecov -f coverage/clover.xml -t $CODECOV_TOKEN
[2022-10-10T17:17:46.271Z] ['info'] 
     _____          _
    / ____|        | |
   | |     ___   __| | ___  ___ _____   __
   | |    / _ \ / _` |/ _ \/ __/ _ \ \ / /
   | |___| (_) | (_| |  __/ (_| (_) \ V /
    \_____\___/ \__,_|\___|\___\___/ \_/
  Codecov report uploader 0.3.2
[2022-10-10T17:17:46.277Z] ['info'] => Project root located at: /builds/laylatichy_projects/reshepe/clients/web
[2022-10-10T17:17:46.285Z] ['info'] ->  Token found by arguments
[2022-10-10T17:17:46.293Z] ['info'] Searching for coverage files...
[2022-10-10T17:17:46.348Z] ['info'] => Found 1 possible coverage files:
[2022-10-10T17:17:46.348Z] ['info'] Processing /builds/laylatichy_projects/reshepe/clients/web/coverage/clover.xml...
[2022-10-10T17:17:46.351Z] ['info'] Detected GitLab CI as the CI provider.
[2022-10-10T17:17:46.352Z] ['info'] Pinging Codecov:*******&branch=release&build=3151933253&build_url=&commit=206377339969e6ac6235dfc7f477dad9466eb1e8&job=&pr=&service=gitlab&slug=laylatichy_projects%2Freshepe%2Fclients%2Fweb&name=&tag=&flags=&parent=
[2022-10-10T17:17:46.646Z] ['info']
[2022-10-10T17:17:46.646Z] ['info'] Uploading...
[2022-10-10T17:17:47.007Z] ['info'] {"status":"success","resultURL":""}
Cleaning up project directory and file based variables
Job succeeded

Expected Results

Post comment on pr, add codecov/patch and codecov/project to CI

Actual Results

team bot is missing

Additional Information

project codecov.yml

    bot:                x.laylatichy.x
    require_ci_to_pass: false

                target: 80%
                target: 80%

        carryforward: true

    require_changes: false

codecov.yml detected on the website


I saw in the other threads mentioning of webhook

but couldn’t find any info in the documentation


Hi @x.laylatichy.x, this is strange, but I’m wondering if there’s just a bad token in our system. Do you mind logging out, clearing all Codecov cookies, and logging back in? I would see if a new commit then would resolve that error message.

Hi @tom, thanks for the reply,

Yeah I tried that already I’m just running codecov exec in verbose mode so i’ll post the output here,

that’s the output on pr to the default branch

$ chmod +x codecov
$ ./codecov -f coverage/clover.xml -t $CODECOV_TOKEN -v
[2022-10-22T23:33:54.035Z] ['verbose'] Start of uploader: 1666481634035...
[2022-10-22T23:33:54.037Z] ['info'] 
     _____          _
    / ____|        | |
   | |     ___   __| | ___  ___ _____   __
   | |    / _ \ / _` |/ _ \/ __/ _ \ \ / /
   | |___| (_) | (_| |  __/ (_| (_) \ V /
    \_____\___/ \__,_|\___|\___\___/ \_/
  Codecov report uploader 0.3.2
[2022-10-22T23:33:54.041Z] ['info'] => Project root located at: /builds/laylatichy_projects/reshepe/clients/web
[2022-10-22T23:33:54.049Z] ['info'] ->  Token found by arguments
[2022-10-22T23:33:54.050Z] ['verbose'] Start of network processing...
[2022-10-22T23:33:54.050Z] ['verbose'] Searching for files in /builds/laylatichy_projects/reshepe/clients/web
[2022-10-22T23:33:54.059Z] ['verbose'] coveragepy is not installed
[2022-10-22T23:33:54.059Z] ['info'] Searching for coverage files...
[2022-10-22T23:33:54.116Z] ['verbose'] Preparing to clean the following coverage paths: coverage/clover.xml,coverage/clover.xml
[2022-10-22T23:33:54.119Z] ['info'] => Found 1 possible coverage files:
[2022-10-22T23:33:54.119Z] ['verbose'] End of network processing
[2022-10-22T23:33:54.119Z] ['info'] Processing /builds/laylatichy_projects/reshepe/clients/web/coverage/clover.xml...
[2022-10-22T23:33:54.123Z] ['info'] Detected GitLab CI as the CI provider.
[2022-10-22T23:33:54.123Z] ['verbose'] -> Using the following env variables:
[2022-10-22T23:33:54.123Z] ['verbose']      CI_BUILD_ID: 3213677920
[2022-10-22T23:33:54.123Z] ['verbose']      CI_BUILD_REF: 10cc2ba67a720ebd10bc74b28473b6c6dae4dd68
[2022-10-22T23:33:54.123Z] ['verbose']      CI_BUILD_REF_NAME: version/0.0.41
[2022-10-22T23:33:54.123Z] ['verbose']      CI_BUILD_REPO: undefined
[2022-10-22T23:33:54.124Z] ['verbose']      CI_COMMIT_REF_NAME: version/0.0.41
[2022-10-22T23:33:54.124Z] ['verbose']      CI_COMMIT_SHA: 10cc2ba67a720ebd10bc74b28473b6c6dae4dd68
[2022-10-22T23:33:54.124Z] ['verbose']      CI_JOB_ID: 3213677920
[2022-10-22T23:33:54.124Z] ['verbose']      CI_MERGE_REQUEST_SOURCE_BRANCH_SHA: 
[2022-10-22T23:33:54.124Z] ['verbose']      CI_PROJECT_PATH: laylatichy_projects/reshepe/clients/web
[2022-10-22T23:33:54.124Z] ['verbose']      CI_REPOSITORY_URL:
[2022-10-22T23:33:54.124Z] ['verbose']      GITLAB_CI: true
[2022-10-22T23:33:54.124Z] ['verbose'] Using the following upload parameters:
[2022-10-22T23:33:54.124Z] ['verbose'] branch
[2022-10-22T23:33:54.124Z] ['verbose'] build
[2022-10-22T23:33:54.124Z] ['verbose'] buildURL
[2022-10-22T23:33:54.124Z] ['verbose'] commit
[2022-10-22T23:33:54.124Z] ['verbose'] job
[2022-10-22T23:33:54.124Z] ['verbose'] pr
[2022-10-22T23:33:54.124Z] ['verbose'] service
[2022-10-22T23:33:54.124Z] ['verbose'] slug
[2022-10-22T23:33:54.124Z] ['verbose'] name
[2022-10-22T23:33:54.124Z] ['verbose'] tag
[2022-10-22T23:33:54.124Z] ['verbose'] flags
[2022-10-22T23:33:54.124Z] ['verbose'] parent
[2022-10-22T23:33:54.125Z] ['info'] Pinging Codecov:*******&branch=version%2F0.0.41&build=3213677920&build_url=&commit=10cc2ba67a720ebd10bc74b28473b6c6dae4dd68&job=&pr=&service=gitlab&slug=laylatichy_projects%2Freshepe%2Fclients%2Fweb&name=&tag=&flags=&parent=
[2022-10-22T23:33:54.125Z] ['verbose'] Passed token was 36 characters long
[2022-10-22T23:33:54.125Z] ['verbose']
        Content-Type: 'text/plain'
        Content-Encoding: 'gzip'
        X-Reduced-Redundancy: 'false'
[2022-10-22T23:33:54.406Z] ['info']
[2022-10-22T23:33:54.407Z] ['verbose'] Returned upload url:
[2022-10-22T23:33:54.407Z] ['info'] Uploading...
[2022-10-22T23:33:54.725Z] ['info'] {"status":"success","resultURL":""}
[2022-10-22T23:33:54.725Z] ['verbose'] End of uploader: 690 milliseconds
Cleaning up project directory and file based variables
Job succeeded

edit: just tried with a fresh gitlab and codecov account

tried username with @, without, tried email address, same issue

@x.laylatichy.x have you tried doing

  bot: codecov_laylatichy


@x.laylatichy.x are you setting this in the global yaml section?