PRs not registering in codecov/PR status

@tom I tried logging in in incognito to be extra sure, and nothing is different. What should I try next?

Here’s an open PR (I’m about to merge): https://github.com/ljharb/es-abstract/pull/101 that shows up on codecov: https://codecov.io/gh/ljharb/es-abstract/pull/101 but has no coverage data, altho the travis build: https://travis-ci.com/github/ljharb/es-abstract/jobs/345448483#L24192 successfully piped it to the codecov bash script.

This project has a very large number of tests (nearly 23,000) and files - is there a chance it’s hitting some kind of processing limit inside codecov?

Hi @ljharb, would it be possible to run the bash command as a separate line item? Codecov typically produces an output which shows some debugging steps that are missing in the travis builds.

I’m not sure what output would be different that way - bash <(curl -s https://codecov.io/bash) -f coverage/*.json shouldn’t provide any different output being behind a &&, i think.

Hmmm you might be right @ljharb. Typically, though, this is the output we would expect

$ bash <(curl -s https://codecov.io/bash) -t 03409ff2-51f3-4742-8841-4a1d0c480f3a
  _____          _
 / ____|        | |
| |     ___   __| | ___  ___ _____   __
| |    / _ \ / _` |/ _ \/ __/ _ \ \ / /
| |___| (_) | (_| |  __/ (_| (_) \ V /
 \_____\___/ \__,_|\___|\___\___/ \_/
                              Bash-20200602-f809a24
==> Travis CI detected.
    project root: .
    Fixing merge commit SHA
    Yaml not found, that's ok! Learn more at http://docs.codecov.io/docs/codecov-yaml
==> Running gcov in . (disable via -X gcov)
==> Python coveragepy exists disable via -X coveragepy
    -> Running coverage xml
==> Searching for coverage reports in:
    + .
    -> Found 1 reports
==> Detecting git/mercurial file structure
==> Appending build variables
    + TRAVIS_OS_NAME
    + 2.7
==> Reading reports
    + ./coverage.xml bytes=1549
==> Appending adjustments
    https://docs.codecov.io/docs/fixing-reports
    -> No adjustments found
==> Gzipping contents
==> Uploading reports
    url: https://codecov.io
    query: branch=master&commit=e4833c0777fc8d0f4389d3c7c70ffb23e4cd62ef&build=28.1&build_url=&name=&tag=&slug=thomasrockhu%2Fexample-python&service=travis&flags=&pr=1&job=347608585
    -> Pinging Codecov
https://codecov.io/upload/v4?package=bash-20200602-f809a24&token=secret&branch=master&commit=e4833c0777fc8d0f4389d3c7c70ffb23e4cd62ef&build=28.1&build_url=&name=&tag=&slug=thomasrockhu%2Fexample-python&service=travis&flags=&pr=1&job=347608585
    -> Uploading
    -> View reports at https://codecov.io/github/thomasrockhu/example-python/commit/e4833c0777fc8d0f4389d3c7c70ffb23e4cd62ef

(https://travis-ci.com/github/thomasrockhu/example-python/builds/170884857#L200)

I can’t think of anything else you are doing that would be hiding this output.

hm, i’ve never seen that output anywhere before. Looking at https://codecov.io/bash, all the output is via the say function which just echos to stdout, so the only things i can think of is either “travis-ci is doing something weird to suppress the output”, or, “the thing that’s failing is triggering the -e or the pipefail and exiting before there’s any output in the first place”. Not sure how to debug further.

@ljharb, apologies, it looks like you don’t have that output on test runs unless COVERAGE=true, and that is all well.

Again, this is, without a doubt, a permissions issue with the integration. I would advise going here and checking that you have the permissions set properly on your repositories and organization. You should be seeing

If you are not, you will have to uninstall and re-install the app

I do see all those permissions green, and i see the repo in question (ljharb/es-abstract) selected.

@ljharb, I’m really sorry I don’t have a good answer for you here at all. I’m going to guess that the integration via GitHub got corrupted somehow. Would you be able to reinstall the app?

Thanks; i tried that and it seemed to work!

It’d be great to have a page in Codecov to refresh whatever’s needed, but at least it’s working now. Thanks!

1 Like

Great, I’m so glad that worked for you. Sorry it took so long to resolve. As for a refresh, thanks for the feedback! Clearly this would have been easier to make self-service, and I will make a note to the product team.

1 Like

Hi Tom - I’m now suddenly seeing this issue again, despite codecov working for many months. See https://github.com/ljharb/es-abstract/pull/123 (compare with https://app.codecov.io/gh/ljharb/es-abstract/compare/123, which does have a report)

@ljharb, I’m seeing a permissions issue here. I’m just curious, What happens if you push a commit on top of this PR?

What sort of permissions issue? You can see in the PR timeline that i’ve already force pushed it twice. I can add a commit, but i’d still need to rebase it back out and force push it before I could land the PR.

@ljharb, sorry on the delay here. Would you mind pushing up a new commit (or a new PR)? We made a small change on our end.

Unfortunately the user deleted their fork, so I can’t alter the PR. I’ll see about updating a new one tho.

I rebased https://github.com/ljharb/es-abstract/pull/103, and the codecov statuses still aren’t getting set.

Everything was working fine, and then suddenly [New] `parse`: add `allowSparse` option for collapsing arrays with missing indices by 1cheese · Pull Request #312 · ljharb/qs · GitHub stopped reporting codecov status (the first rebase reported it, the last one failed to do so).

@ljharb, I’m sorry this has gone on for so long for you. I’ve made an issue with the product team, but we may need you to push up a new commit next week if you don’t mind. Thanks for your patience as we try to investigate the issue.

I ended up having to rebase it anyways, and once done, the codecov checks worked. It’d be great to solve the root cause, though.

@ljharb, got it. We will likely need a new commit when that happens. If it’s working for you now, then maybe it was a fix we had indirectly made. If it happens again, please post here.