GitHub bot comment not triggering

Several weeks ago Codecov stopped posting comments on GitHub and stopped updating the GitHub status checks. Since then we have tried uninstalling/installing Codecov, enabling/disabling the repo, and removing the .codecov.yaml all to no avail. I have not been able to find much in the way of logs to debug this and we are at a bit of a loss on how to fix this.


ERROR GitHub HTTP 403 {"body": "{\"message\":\"Resource not accessible by integration\",\"documentation_url\":\"\"}", "bot": "n/a", "endpoint": "/repos/MolSSI/QCElemental/statuses/949a0c60d321f2f8b3130d7ee70978f674b10bc3", "event": "api", "method": "POST", "public": "t", "pull": "87", "rlr": "1565554053", "rlx": "4953", "rly": "5000", "service": "github", "slug": "MolSSI/QCElemental", "task": "sync"}

You say you removed and add the Codecov app on GitHub? GitHub is telling us we have no permission to post statues. Can you try again , please? (making sure that the app is authorized for your org, and not only at the personal level)

Thank you for the fast reply. I double checked and the QCElemental repository did have access, I have went ahead and allowed access to all repositories.

Cool. Let me know if you still have issues, and if you can share a SHA that helps me track it down in the logs

Sorry, I wasn’t clear. Adding access to all repositories did not fix this. Commit here:

@drazisil Any updates here?

Hi @dgasmith, sorry for the delay, I was out for a couple days.

Sadly, no, GitHub is still saying the Codecov app does not have access

Aug 14, 2019 at 16:53:00.654 UTC

ERROR GitHub HTTP 403 {"body": "{\"message\":\"Resource not accessible by integration\",\"documentation_url\":\"\"}", "bot": "n/a", "endpoint": "/repos/MolSSI/QCElemental/statuses/cfb229c6d1daead0336655342d5028394905d69b", "event": "api", "method": "POST", "public": "t", "pull": 87, "rlr": "1565803201", "rlx": "4994", "rly": "5000", "service": "github", "slug": "MolSSI/QCElemental", "task": "sync"}

I’m wondering if the app was installed by someone who no longer has access to the repo. Can you (or an org admin) try removing and reinstalling it?

If that doesn’t work, you may need to take the log lines I’ve shared to GitHub support and see if they can track down in their logs why they are rejecting us.

@drazisil comment and commit status has also stopped working for me. Could you check if my repo is having the same root cause?

Can you share a recent commit SHA? It’s much easier to lookup that way.

@drazisil sure thing

SHA: 604e4cb7c7ea47814d939d76da66a62e717c8ff7

Thanks. It actually is the same issue as above:

ERROR GitHub HTTP 403 {"body": "{\"message\":\"Resource not accessible by integration\",\"documentation_url\":\"\"}", "bot": "n/a", "endpoint": "/repos/microsoft/VoTT/statuses/604e4cb7c7ea47814d939d76da66a62e717c8ff7"

@drazisil thanks, looks like uninstalling/reinstalling the app fix the problem

1 Like

@drazisil any idea why this happened?

Is there any roadmap to expose these errors on the the codecov portal so users can self diagnose when this happens?

My guess is the app was installed by someone who no longer has access to the repo.

Regarding better surfacing errors, that is something absolutely something we are focused on. We have a new frontend coming soon that will make changes a lot easier for us, and I believe surfacing errors is next in line after that release.

Good to hear about the new UI coming.

The app was install by a service user and I have verified that it still have permission.

Same for me, I originally authorized the app and have ownership permissions.

I have tried uninstalling the app again, but now it is taking some time to propagate and I cannot reinstall it. Will check back in tomorrow morning, but this process does have some trouble spots.

Thanks for the feedback and working through these issues! We really like Codecov and currently support it as the recommended way of code coverage under our “best practices” for computational molecular scientist through both documentation and a cookiecutter which is used by a few hundred projects.

@drazisil I am now seeing this again on a particular branch. I created 2 more test PRS and those all work fine. I closed the problematic PR, rename the branch, and open a new one, same problem.

Here’s the sha: c1d2aa6f3071c8be261485e94a3988a3798998e3

It also looks like the notifications is pending CI completion but clicking “Push notifications now” does nothing


This is a separate issue we are investigating where the report takes too long to process on upload (may be size related, may not) and the rest of the process jams.

Re-uploading the report may fix this. Can you share a bit more about your upload step, are you using the bash uploader or another method? You can also view the file you are sending us by adding -d to the end of the bash uploader, this will output the report, instead of uploading. I’ve seen cases where it tries to list all files in the filesystem, for example.


Please let me know if you are able to get it added back, and if it fixes the issue. Even if my hunch to the cause is wrong, I hope it gets it working again.

@drazisil Hmm, Codecov bot is off and web hooks are gone, but getting some odd triple reporting here:

About 3.5 hours late strangely.