Codecov status stuck at "waiting for status to be reported" on github


recently we had experiences an issue with codecov’s status stuck at expecting results.

We found it might be related to a failed upload
==> Circle CI detected.
project root: .
–> token set from env
Yaml found at: .codecov.yml
==> Running gcov in . (disable via -X gcov)
==> Python coveragepy not found
==> Searching for coverage reports in:
+ .
-> Found 1 reports
==> Detecting git/mercurial file structure
==> Reading reports
+ ./coverage.txt bytes=1672714
==> Appending adjustments
+ Found adjustments
==> Gzipping contents
==> Uploading reports
query: …
-> Pinging Codecov
-> Uploading
X> Failed to upload
-> Sleeping for 30s and trying again…
-> Pinging Codecov
-> Uploading
-> View reports at

We’re guessing if the first failed upload triggered the codecov to run some pipeline like fetch status, calculate diff, etc, but the 2nd time also triggered another one and masked the first one, but some race conditions caused the codecov status on github to hang?

Could someone help on this? I masked our github projects/repo info, and we’re using codecov cloud (, please let me know if you need any more info.



Additional Information

1 Like

I have this exact same problem. Sometimes just re-runig the pipeline fixes ths issue, but sometimes don’t.

I’m currenlty with one PR open beause of this. It’s a private project and it belongs to a paid organization.

Anyone from support team could take a look and help us debug this issue? I can give more information about the project if needed.


Hello @tom,

could you help us debug this problem? I think we need some help from inside codecov.


1 Like

Hi @billcchung

When you check the Codecov URL, what does it say? Error processing, waiting on CI, etc? Is this a paid or unpaid account?

Hi @daltonmatos

Since this is a paid account, can you please open a ticket? That way you can share the URLs with us and it will be much easier to troubleshoot.

Hello @drazisil,

Thanks for reaching out. The ticket is open, ist number is 1835. I already posted some links there.


1 Like

Thanks @daltonmatos

That ticket is waiting for one of our engineers to take a look, I’ll take a look tomorrow as well.

1 Like

Hi @drazisil,
We just setup new app and have same problem, but in run in Bitrise. Sometimes it upload successfully but almost failed and sleeping.
Can you resolve it as soon as possible for us?
Many thanks

Hi @vuphan365

We just fixed a bug last night regarding statuses getting stuck and not posting. Can you please push a fresh commit and let me know if you are still seeing this issue?

Still broken sometime,

Uploading reports
    View report at:

but status always pending


Hi @echoulen

I’m showing we sent notifications for that commit. Was it delayed, or is it still not showing?

Hi @drazisil

This often happened on (GMT+8) 4:00 ~ 7:00, the report push success, but the status of pull request not updated, it does not depend on delay, because it’s will never update the status for this pull request.

I guess the codecov receive the reported success but request to GitHub failure, it sustained a long time,
please check the issue, thank you


We notify if update PR status missing, rebuild and report to codecov with same commit will not working,
the one way to resolve it only push new commit and trigger the codecov report

I am having the same problem with our open source project. I have verified that the reports are uploaded successfully and can see it on the Codecov portal. Rerunning the pipeline no matter how many does not help.

I have also remove and readded the repo and that doesn’t help either

PS. I have to disable the codecov commit status to unblock our PRs so you won’t see it in the status check

Not sure how to fix this issue if you could be a little more specific. I would greatly appreciate that.

==> Uploading reports

752 url:

753 query: branch=master&commit=9ce5251e92bbf1e27dba50e76611cc26be48d6e0&build=168.8&build_url=&name=&tag=&slug=KomodoPlatform%2Fantara-gaming-sdk&service=travis&flags=&pr=false&job=237913967

754 -> Pinging Codecov


756 -> Uploading

757 X> Failed to upload

758 -> Sleeping for 30s and trying again…

759 -> Pinging Codecov


761 -> Uploading

762 X> Failed to upload

763 -> Sleeping for 30s and trying again…

764 -> Pinging Codecov


766 -> Uploading

767 X> Failed to upload

768 -> Sleeping for 30s and trying again…

769 -> Pinging Codecov


771 -> Uploading

772 X> Failed to upload

773 -> Sleeping for 30s and trying again…

774 -> Uploading to Codecov

775 -> Sleeping for 30s and trying again…

776 -> Sleeping for 30s and trying again…

777 -> Sleeping for 30s and trying again…

778 -> Sleeping for 30s and trying again…

779 X> Failed to upload coverage reports

Same error for public repository here

1 Like

Cam you please add the -v flag to the bash uploader command so we can see what error the server is returning?

very verbose but if you can explain me what is wrong

curl: (92) HTTP/2 stream 1 was not closed cleanly: PROTOCOL_ERROR (err 1)


lol seems my report is too big ?

Not sure. Let me go through the errors and see what I can figure out.

I believe this is case, that it’s too big for the upload to buffer. Is it possible you for to split the reports down to ~5mb and upload them separately? This should work, please let me know if it does not.