Report stuck in processing - Unable to find report content in storage archive

I am also facing the same issue with our github project. I observed that if the pull request is created using a private branch it would fail but if the pull request is with already merged branch it’s working fine.

This issue has come up again for me too. Here’s a screenshot of my commits right now:

Same here.
In CI I see:

 -> Uploading
    -> View reports at

On that link I see:

Unable to find report content in the storage archive.

On the commits page, the last 8 commits, which happened in the last 18 days say: Processing...
I wonder if there’s anything I can do to fix this.

I’m having the exact same issue with a new project I set up yesterday:

Joining the club - the same issue, no reports have been processed in the past 2 weeks. It always worked previously and no changes to the pipeline had been made. CI logs say that uploads are successful every time…

Same issue for me:

This certainly worked at least some months ago, it’s been a little while since I’ve worked on this project and noticed that no reports are being processed.

Same issue:

@drazisil Do you have any ideas/comments on the issue? It looks like many users are affected?

Looks like the same issue that was being discussed over here: Unable to find report content in the storage archive

Hey everyone, thanks for your contributions and apologies for the issue.

We started an open issue tracker on this here: OPEN ISSUE INVESTIGATION: Report stuck in processing + Unable to find report content in storage archive

This is affecting about 1% of users. We are rapidly looking for a root cause fix or a workaround we can deliver to you all. More updates to come on the thread above.

Hi I’m getting the same issue too. Is there an update on this?

The general issue is resolved. If you are still seeing this, please share a recent commit SHA so we can investigate.

Hi @drazisil I am seeing this with this commit
which is not showing up here
(and that is the first after a gap as I had temporarily borked the coverage report creating in my Docker-based Travis run so it would have been the first after a little while).

Edit: It worked fine on the subsequent commit.

Hi @eddelbuettel

Something happened when we tried to fetch the commit from GitHub, the task just…stopped. Can you let me know if it happens again?

It’s been fine since.

This may have been due to me goofing the setting so that updates lapsed for just over three weeks, and this initial load maight have carried ‘too much’ new information?

In any event, it looks fine now. Thanks for looking into it.

1 Like

Still same behavior.


Can’t insert travis since “new user can post only two links”, so travis is on main project page under build badge.

Hi @pohmelie

It looks like you uploaded an empty report:

(also, I upgraded your access so the links restriction is removed)

Oh… my bad, I missed pytest coverage generation cli attribute. :man_facepalming:
Now it works, thank you!

1 Like

I’m going to close this thread, since the initial issue was resolved. Please start a new one if you are seeing this message.