Server error on GitHub login

Hey everyone!
I tried logging in to Codecov using GitHub login, but I get "Server Error (500)" everytime I try to login. I tried incognito mode and changing the browsers, but the error still persists. Screenshot below:

I think there may be a problem with GitHub login? Or is there an error on my side?

Have a nice day!

1 Like

Hello, I am having the same exact issue as @tavsec:

Screenshot 2023-01-02 at 12.42.56 PM

Something must be broken with Codecov’s GitHub authentication flow. I also tried different browsers, incognito mode, nothing worked. But when I tried a different GitHub account, I managed to log in.

My GitHub account is associated with an organization which had granted access to Codecov in the past. Not sure if this is relevant, but I thought to mention it in case it helps for debugging purposes.

Is anyone monitoring this forum, or at least the contact form on

I tried to reach out to you via the form, but nobody replied.

@tavsec @PaulRBerg there isn’t a problem that I’m aware of. Have you tried to removing Codecov cookies and trying to log in again?

Are you able to share the GH usernames you are using?

@tom thanks for the quick reply.

I just explicitly removed the Codecov cookies with the Edit this cookie extension, re-tried logging in, and got the same error. However, I knew this was going to happen, since as I said above I tried logging it in an Incognito window and I still got the same error.

My GitHub username is “paulrberg”, and the GitHub organization that used to be connected to Codecov is “sablierhq”.

@tom thanks for the reply, I also tried deleting the cookies, but it does not seem to work. My Github username is tavsec.

@tom the issue continues to persist, this is a major blocker. We’d like to use Codecov but we simply cannot sign in.

Is there anything I could do to help you debug this? Share console logs, record my screen, etc.?

Hey @tavsec @PaulRBerg, sorry I was out sick over the past few days.

I think the team is going to need a few more details to debug this. If you could provide a few more details about how you are getting to this page that would be useful. In particular, what URL you are starting at, what login page you see, and if this is the first page you see on login.

Thanks for your patience, I know this is a little frustrating.

Hey @tom , so here are the steps:

  1. I tried to login on Codecov landing page ( by hovering the Login button on the left side of navigation, and selecting GitHub

  2. On the next step, I click on the “Login with GitHub” button

  3. On the GitHub Authorize page, I grant access to the only organization that I need to use Codecov on (the last one on the screenshot)

  4. I click on Authorize codecov button

  5. I get redirected to Codecov, but it returns error 500

I hope this is enough for your team to debug/reproduce. Otherwise, I can provide more info.

1 Like

@tom not sure what you guys did in the meantime, but logging in worked now!

@tavsec can you try again, too?

@PaulRBerg I tried, still doesn’t work unfortunately :frowning: . Did you do anything different that I did in the message that I posted above?

Oh, sorry to hear that.

I didn’t do anything different - just went back to the landing page, clicked on "Login, and so forth.

It might be worth it to try to invalidate the access that Codecov has to your GitHub account. I did this a few weeks ago. Maybe this is some sort of sneaky cache invalidation issue?

I tried completely removing all of the Codecov “connections” from my Github account, still no luck tho :frowning: . Will wait for @tom’s response.

@tavsec, the majority of the team is on holiday until Tuesday. I’ll get back to you then.

1 Like

I’ve the exact problem. I don’t have any connection between Codecov-GitHub. Cookies erased and tried on incognito.

I’m on GitHub Student Pack, Idk if it can affect this issue.
Also, I checked if deleting an account is the problem, it isn’t; I tested because I deleted my account years ago.
Please, I need the integration on my repository. Thx!

@tavsec @hugovidafe we have identified a bug that is causing this issue and are working on a fix

1 Like

I’ve been having the same issue. Been trying to log in for over a month… GitHub username abemedia.
I tried deleting cookies and removing the connection on GitHub. Also used to contact form to contact you guys around a month ago but still no reply…

What’s ETA on the fix?

@abemedia I don’t have an ETA, but the fix is in review. I’ll reply back here when it’s in. Hopefully this will solve the issue.

Yep, I changed my GH’s username, logged in, and renamed back, so now I’m inside, I’m not gonna log out for some time. Thx @axieum!