OAuthing with GitHub on 2 different browsers causes one of them to 401

Steps to Reproduce

  1. Open one browser, go to https://codecov.io/login, and log in with GitHub.
  2. Open another browser and log in with GitHub.
  3. Refresh the page in the first browser.

Expected behavior:

Both browsers stay logged in to Codecov.

Actual behavior:

The first browser begins 401ing! Screenshot:

Clicking the “Login with GitHub” button doesn’t work. I have to open DevTools, clear my cookies for codecov.io, and log in again. But then that breaks the other session…


This is 100% reproducible (for me, at least). It’s extremely frustrating because I switch between multiple machines on a regular basis, so I have to keep logging in and out.

Additional Information

This bug is so weird that I feel like somebody else would have noticed it, so it’s possible it’s something specific to my account (my GitHub username is also cptpcrd).

I also believe that this may have been a recent change (i.e. within the past few weeks), but I’m not completely sure about that.

Hi @cptpcrd, looks like this is a permissions issue. Would you be able to clear your cookies, log out, and revoke permissions to Codecov here? Then log in and re-grant permissions to Codecov.

I thought I’d tried that already (I did everything I could think of before opening this thread), but I tried again and it works now. :slight_smile: Thanks!

1 Like