There was an error processing coverage reports. - always empty

Before submitting a topic, please confirm the following

I have searched for similar issues before creating this topic.
I have verified that my repository is using the Codecov GitHub app, if using GitHub
I have filled out the below sections to the best of my ability.


I recently switched from CircleCI to Github Actions. It was working fine with CircleCI, but I can’t get it to work with GithubActions. I tried a variety of ways

  1. using exact same tools as used on circle ci. Specifically the uploader came from pip install codecov. no errors in the log, but empty upload error
  2. still using the same code generator as circle ci, but switched to codecov/codecov-action@v3 as uploader.
    a) I tried without the files key and setting working directory → didn’t work at all.
    b) with files pointing to .coverage → upload success, but error processing on website
    c) as I was also generating html pointed it to /htmlcov/ thinking the old codecov tool might take it from there. Learned .coverage and .html are not supported . Unclear how the old codecov tool worked but result the same as in b)
    d) changed coverage generator to output json, cat coverage.json in the generation step to confirm it has content prior to uploading → still same result as b) & c)
    e) did a test by not specifying files, uploader automatically finds coverage.json but still same result as b, c, d

I’m close to start looking for a different coverage provider, but at the same time giving it a final chance trying to get help here


Codecov Output

Run codecov/codecov-action@v3
    files: coverage.json
    working-directory: ./mamba/
    env_vars: OS,PYTHON
==> linux OS detected
==> SHASUM file signed by key id 806bb28aed779869
==> Uploader SHASUM verified (66cbf87269acc529c87f6ea29395ba329f528e92cfda4fc199eab460123e18b6  codecov)
==> Running version latest
==> Running version v0.2.5
/home/runner/work/_actions/codecov/codecov-action/v3/dist/codecov -n  -Q github-action-3.1.0 -e OS,PYTHON -f coverage.json
[2022-08-02T19:13:24.621Z] ['info'] 
     _____          _
    / ____|        | |
   | |     ___   __| | ___  ___ _____   __
   | |    / _ \ / _` |/ _ \/ __/ _ \ \ / /
   | |___| (_) | (_| |  __/ (_| (_) \ V /
    \_____\___/ \__,_|\___|\___\___/ \_/

  Codecov report uploader 0.2.5
[2022-08-02T19:13:24.643Z] ['info'] => Project root located at: /home/runner/work/neo-mamba/neo-mamba/mamba
[2022-08-02T19:13:24.644Z] ['info'] -> No token specified or token is empty
[2022-08-02T19:13:24.656Z] ['info'] Searching for coverage files...
[2022-08-02T19:13:24.930Z] ['info'] => Found 1 possible coverage files:
[2022-08-02T19:13:24.931Z] ['info'] Processing /home/runner/work/neo-mamba/neo-mamba/mamba/coverage.json...
[2022-08-02T19:13:24.936Z] ['info'] Detected GitHub Actions as the CI provider.
[2022-08-02T19:13:24.938Z] ['info'] Pinging Codecov:*******&branch=fix-codecov&build=2784603360&
[2022-08-02T19:13:25.595Z] ['info']
[2022-08-02T19:13:25.595Z] ['info'] Uploading...
[2022-08-02T19:13:25.794Z] ['info'] {"status":"success","resultURL":""}

Expected Results

have coverage results working

Actual Results

upload is empty

Additional Information

surprisingly on the codecov website it says CI failed

whereas on Github it shows it didn’t
ci: fix codecov source by ixje · Pull Request #175 · CityOfZion/neo-mamba · GitHub (can’t add 2 images, so linking to the PR)

nevermind, moved away from codecov to an alternative provider.

@ixje I’m sorry this took us so long to get back to you about. If you do decide to use Codecov again, I think you are missing a coverage xml step before running the uploader.