We were not able to activate this repo

Before submitting a topic, please confirm the following

I have searched for similar issues before creating this topic.
I have verified that my repository is using the Codecov GitHub app, if using GitHub
I have validated my codecov.yaml configuration file.
I have filled out the below sections to the best of my ability.
I understand that the community boards are a free, best-effort tool. While we hope to have someone on the Codecov team resolve your problem quickly, this is not always possible.


This repository was changed from private to public (and renamed from symlnk → symlnk-cli), and then it showed as deactivated, unable to be activate or uploaded.

I have tried to log in again and resynchronize, but still cannot solve the problem.


Codecov Output

[2023-06-12T17:12:21.923Z] ['info'] 
     _____          _
    / ____|        | |
   | |     ___   __| | ___  ___ _____   __
   | |    / _ \ / _` |/ _ \/ __/ _ \ \ / /
   | |___| (_) | (_| |  __/ (_| (_) \ V /
    \_____\___/ \__,_|\___|\___\___/ \_/

  Codecov report uploader 0.5.0
[2023-06-12T17:12:21.934Z] ['info'] => Project root located at: /home/runner/work/symlnk-cli/symlnk-cli
[2023-06-12T17:12:21.935Z] ['info'] ->  Token found by environment variables
[2023-06-12T17:12:21.946Z] ['info'] Searching for coverage files...
[2023-06-12T17:12:22.122Z] ['info'] Warning: Some files located via search were excluded from upload.
[2023-06-12T17:12:22.123Z] ['info'] If Codecov did not locate your files, please review https://docs.codecov.com/docs/supported-report-formats
[2023-06-12T17:12:22.124Z] ['info'] => Found 2 possible coverage files:
[2023-06-12T17:12:22.125Z] ['info'] Processing /home/runner/work/symlnk-cli/symlnk-cli/coverage/clover.xml...
[2023-06-12T17:12:22.127Z] ['info'] Processing /home/runner/work/symlnk-cli/symlnk-cli/coverage/coverage-final.json...
[2023-06-12T17:12:22.131Z] ['info'] Detected GitHub Actions as the CI provider.
[2023-06-12T17:12:22.599Z] ['info'] Pinging Codecov: https://codecov.io/upload/v4?package=github-action-3.1.4-uploader-0.5.0&token=*******&branch=main&build=5246417401&build_url=https%3A%2F%2Fgithub.com%2Fu3u%2Fsymlnk-cli%2Factions%2Fruns%2F5246417401%2Fjobs%2F9475457133&commit=3beab91d1cccd441c1c20ed1b451aaa2afb3789a&job=CI&pr=&service=github-actions&slug=u3u%2Fsymlnk-cli&name=&tag=&flags=&parent=
[2023-06-12T17:12:22.793Z] ['error'] There was an error running the uploader: Error uploading to https://codecov.io: Error: There was an error fetching the storage URL during POST: 400 - [ErrorDetail(string='This repository has been deactivated. To resume uploading to it, please activate the repository in the codecov UI: https://app.codecov.io/github/u3u/symlnk-cli/settings', code='invalid')]

@qwq have you tried going to the settings link as a user with GitHub admin rights?

Of course, I am the administrator. The error message is given when I click the Activate button.

I am having a similar issue, except in my case the repository name wasn’t even changed. Did you find a solution in the end?

For the record, 12 hours later activating the repo worked :person_shrugging:

@qwq got it. I’m sorry, this got away from me. Let me sync up with our product team tomorrow and get this fixed for you.

@elinscott apologies, I’m really not sure why this didn’t sync more quickly so that you could activate. Let me know if it gives you trouble anymore.

1 Like

@qwq looks like there might be something wrong with mismatch on our system. Could you try logging out, clearing cookies, and logging back in?

I have tried all of these, but they still don’t work. However, I just tried activating it after logging in with a private window and it was successful!

But when I switched back to a regular window and tested deactivating it, it still prompted “We were not able to deactivate this repo.”

Perhaps simply logging out of app.codecov.io is not enough, I also need to completely log out of my GitHub account. I will test it.

I tested it, and no matter how I tried, I couldn’t solve the problem with the normal window. Even if I deleted the Codecov application in Authorized GitHub Apps and logged in again, it still didn’t work. Only after logging in with a private window can it be activated.

I found an interesting thing. When I log in to app.codecov.io, the URL is https://app.codecov.io/gh/u3u. Refreshing and entering project settings are fine. However, when I manually enter https://app.codecov.io, it automatically redirects to https://app.codecov.io/login/gh?! This means that I may not have logged in successfully at all.

Holly shit! I finally know what caused the problem! When I disable this browser extension, it works :sweat_smile:
CORS Unblock - Microsoft Edge Addons

Oh wow, nice work @qwq. I don’t think I would have been able to figure that out