Private -> public repo not working

I have a similar situation as in this (now closed) support request:

Specifically, I have a repo that originally was private but now is public:

The codecov for it is 100% but the badge is showing “unknown” and under codecov settings it is showing the message “Repository is activated and using one private repo credit.”
So clearly codecov still thinks my repo is private even though it has been public for days.
I tried removing it from codecov and adding it but it seems it was not really “removed” but rather “archived” so the restored version still has the same issue.
I suspect that only codecov can fix this but if anyone has a work around I’d appreciate it!

Hi @JeffFessler

I’ve confirmed we still have this set as private. I’ve passed your request along to someone who can fix this for you :slight_smile:

Thanks for the status update. I would guess that the pattern of starting with a private repo for initial development and then making it public when it is ready is fairly common, so if there are any “best practices” we should use to avoid this issue in the future please let us know! Thanks!
Other than this small issue, codecov is fantastic!

Ok updated! I haven’t seen this issue before but my guess is that the “private” setting was just cached incorrectly in our DB. If we see it popping up again will look for a more foundational solution.

Happy testing!


@jerrod Got the same issue with my repo

I’ve tried to delete repo and data and add it again, but it doesn’t help.

Hey @SkeLLLa --> I’ve reset the status of this repo to public for you. Let me know if that worked!

@jerrod, thanks. Now it works well.

I have the same issue with my repo:
The related bitbucket repository is public (, but I have no options to change the codecov repo to be public.
Any help would be appreciated!

I have the same issue, my repo is
At first it was private but just because I was prototyping.

@jerrod is it possible to do the same thing of resetting it’s status to my project? thanks

Hey @pabloszx and @herf -->

I’ve confirmed both of these repositories are open source in the code host and therefore set them to public in Codecov accordingly.

This sounds like a good feature for us to build to support more movement towards the open source!!

Thanks for your usage of our product :slight_smile:

1 Like

I have the same issue for my repo:

@jerrod can you fix it? thanks

This should be all set :slight_smile:

I also have the same problem @jerrod:

Hopefully the DB caching fix coming soon! Thanks,

Hey @jessexknight-- did you change the name of this repo? I can make change for you, sorry for delay.

Hi @jerrod, yes I did rename the repo – but I’ve deleted that one now and the one you link is different.

I was setting up a test repo for a workshop later that evening. I changed from private to public half-way through testing, and that seemed to break codecov. I later deleted that repo, and during the workshop made a different one (the one you’ve linked). That one is okay (was always public). I should have updated here after deleting the test repo – nothing for you to do! But I do think the fix should be integrated upstream. Thanks!

Ok thanks @jessexknight – yes, this issue is in our backlog. We should have a fix in coming weeks/months.

1 Like

Hi, @jerrod, I also did as JeffFessler in the same workflow, and can’t be read publicly. I think making a recache or pub/private trigger in general is better, because I found there tripple times, and thought It’s my fault that I missed somthing.

This is my repo:

Hope this issue get well soon :pensive:

I can confirm I have the same issue in the two repos below. Would someone be so kind as to reset their status as well?

As for my repositories above, the former is not being used with my one private token, but the latter is (for the time being) :slight_smile:

Hi everyone, thanks for reaching out here. Looks like it’s a bug on our end.

I’ll pull the list of repositories that we need to switch over from this thread and post back here. Please reply if we have missed yours. We are also following up with the product team to get this fixed. @Tokenyet @phantomraa

1 Like