403 error when trying to view a private repo

Before submitting a topic, please confirm the following

I have searched for similar issues before creating this topic.
I have verified that my repository is using the Codecov GitHub app, if using GitHub
I have validated my codecov.yaml configuration file.
I have filled out the below sections to the best of my ability.
I understand that the community boards are a free, best-effort tool. While we hope to have someone on the Codecov team resolve your problem quickly, this is not always possible.


403 Unauthorized when trying to access the page for a private repo.

It says ‘activation is required to view this repo’ — but I was able to access it just fine a week or two/three back.

I am on the Free plan with Codecov.

I am the owner of the repo, it uploads to Codecov just fine, the cover percentage updates fine on the page listing all of my repos. I have the GH Codecov app installed for the repo in question. My Codecov secret is in place, and working (or I would not be able to push coverage reports from the GH Action)

I have tried resyncing, nothing changed.

On the 403 page, there is a link, to activate my account. It take me to this page Codecov — with a toggle switch that does nothing, and a link to change my plan, which I don’t wish to do.

On that manage members page, it says there are zero members. I can see no way to add myself (if that is indeed what I am now suddenly required to do). It says if I can’t see anyone to add, it is because they haven’t logged in to Codecov yet, but clearly I am already logged in.


I don’t wish to publically disclose the URL of a private repo / project at this time.

Codecov Output


Expected Results

I should be able to view the coverage reports for the repo in question.

Actual Results

I get a 403 unauthorized message, telling me my account needs activation.

Additional Information

The repo in question is the only private repo I currently have activated on this page: Codecov

Please help. This is particularly frustrating.

@jimsmart please provide your GitHub username, and a commit SHA to the repo in question if you do not want to publically disclose the private repo name.

My GitHub username is jimsmart — as in the Codecov URLs I shared above.

The project in question has a commit 81376dd (made about an hour ago).

Many thanks.


I am having the same problem.
GitHub username: mirarcosoftware
Commit ID: 10acd8b

Everything was working as expected a few days ago.
Thank you.

@jimsmart @mirarcosoftware what I suspect is there might be a sync issue on our end.

Can you log out, and then go to this URL (https://codecov.io/login/gh?to=https%3A%2F%2Fapp.codecov.io%2Fgh&private=true) to log back in?

Logging out, and then going to the link you provide… unfortunately changes nothing, I still get a 403 when I click on the repo name on the list of repos.

Additionally, I tried re-syncing to see if that made any difference after logging in via the URL you give, but that did nothing.

I also tried your URL after fully logging out of GH (and Codecov), just to see if actually having to do the auth made any difference. No change. Still 403 on that repo.

— Additionally, since my intial report above, I noticed that whilst my Codecov uploads are working fine, the amount of coverage for this repo is no longer updating on the Repo page, nor on my badges. But it does change on the chart on the Analytics page (if I select this particular private repo from the dropdown menu). The repo page and my badges all say ~72% whereas on the analytics page, coverage has since increased to 75%. IDK if this info helps you pinpoint things any better, or if it is simply just expected whilst private repos are not working properly with Codecov.


Additionally, I notice that there are repos on my main list that I actually deleted from GH a few days back, during some tidying-up (FWIW: these repos have never had Codecov enabled on them. But eitherways, I’d now expect them not to show).

Don’t know if that info helps pinpoint anything, but perhaps worth a mention? Sure: something clearly isn’t syncing (whether that is related to my OP or not, is another matter).

Got it, thanks @jimsmart. This is a bit out of my league now, I’ll bug the support team on Monday.


Ok — All the same: thanks for your support @tom, appreciated.


The link did not change anything for me, either. I signed out and then when to the link, and when I clicked on the link to my repo, I received the same 403.

I am also experiencing the other details described by jimsmart. Everything seems to work fine, except we can’t access the main repo page.

@mirarcosoftware apologies, I don’t think I’ll be able to figure this out over the weekend. I’ll get back to you as quickly as possible next week.

1 Like

@jimsmart you should be unblocked now.

@mirarcosoftware I didn’t explicitly check to see if your problem is also resolved. Are you able to see your repo?


Yes, everything is working as expected. Thank you so much!

1 Like

Yes, everything is now working as expected again, many thanks @tom

1 Like