Weird SSL error from codecov-python when uploading from travis-ci


After years of running without problems, the build of my opensource Java application throws an SSLError while uploading codecov data. For a quick look at the error, go to the CI/CD URL below, scroll down the job log and click on “codecov” to see the output directly.

Commit SHAs



CI/CD or Build URL

Scroll all the way to the bottom of the job log and click on “codecov” to open the uploader output.


codecov-python v2.1.11

Codecov Output

    Travis Detected

    Fixing merge commit SHA

==> Preparing upload

==> Processing gcov (disable by -X gcov)

==> Collecting reports

    + /home/travis/build/parsingdata/metal/formats/target/site/jacoco/jacoco.xml bytes=19104

    + /home/travis/build/parsingdata/metal/core/target/site/jacoco/jacoco.xml bytes=390305

==> Appending environment variables



==> Uploading


    .query pr=331&service=travis&package=py2.1.11&job=479610699&build=357.1&branch=master&commit=db757907804f703bafb7a3f102a93b32b8b285d8&slug=parsingdata%2Fmetal

    Gzipping contents..

    Compressed contents to 21413 bytes

    Pinging Codecov...

Error: HTTPSConnectionPool(host='', port=443): Max retries exceeded with url: /upload/v4?pr=331&service=travis&package=py2.1.11&job=479610699&build=357.1&branch=master&commit=db757907804f703bafb7a3f102a93b32b8b285d8&slug=parsingdata%2Fmetal (Caused by SSLError(CertificateError("hostname '' doesn't match ''",),))

Tip: See an example jdk repo:

Expected Results

Succesful completion of the upload instead of the SSLError.

Actual Results

This error:
Error: HTTPSConnectionPool(host=‘’, port=443): Max retries exceeded with url: /upload/v4?pr=331&service=travis&package=py2.1.11&job=479610699&build=357.1&branch=master&commit=db757907804f703bafb7a3f102a93b32b8b285d8&slug=parsingdata%2Fmetal (Caused by SSLError(CertificateError(“hostname ‘’ doesn’t match ‘’”,),))

Additional Information

If I look at the edits of the codecov bot on Github, it seems to have been working until about 3 hours ago.

@jvdb this is extremely odd. We saw some issues earlier today, but they should be unrelated. Just to double-check, are you still seeing the issue?

@tom I restarted both the PR and branch builds a couple of minutes ago, they both still return this same error!

I fixed it now by switching to the Bash CI uploader. I also understand that there’s not much you can do if nobody has this and it cannot reliably be reproduced. Anyway the linked build log on travis will remain available if anyone needs it.

@jvdb that is fascinating… it only happen on the python uploader?

@tom The Bash uploader works fine yes, so it’s not a connection issue on Travis it seems.