Why only one braces is not covered in my project?


In my project appear in report that only one braces is not covered:


Why this happen?


@paulocoutinhox this is coming from the coverage reports being uploaded to Codecov. You can see on the latest commit here


Notice how the line DA:53,0 is showing 0. That’s why we are showing it as uncovered.

I’m not too adept with C or C flavors, but maybe we can figure this out together. Do you have a CI/CD link to share? Maybe there’s something in the way you are collecting coverage.

Hi man, thanks.

This is from my open source project:

I run lcov and upload to codecov.

Ok, so it’s definitely coming from your MacOS build. Can you walk me through a little in the codebase where this is getting run? Especially with where it’s running lcov

Unrelated, but I would install the Codecov app as well or you’re going to run into connection issues down the line.

Hi, sure!

This is these two lcov calls:

One is:

lcov -d build/tests/debug/x86_64 -c -o build/tests/debug/x86_64/lcov.coverage.info

The other is:

lcov -r build/tests/debug/x86_64/lcov.coverage.info “Xcode.app” “.conan” “/tests/” -o build/tests/debug/x86_64/lcov.coverage.info

After, i upload to codecov:

@paulocoutinhox got it, I’m not totally sure why lcov spits out coverage this way, but I have an inkling on what Codecov can do to fix it up. Let me forward this over to the product team and see what we can do.

Sure. Thanks about your attention.

hi @paulocoutinhox sorry for the delay here. I released a new version of the uploader, would you be able to try updating this for your Codecov Action?

- name: Code Coverage - Upload
  uses: codecov/codecov-action@v3
    files: build/tests/debug/x86_64/lcov.coverage.info
    fail_ci_if_error: true
    functionalities: fixes
    verbose: true

Note the functionalities: fixes line.



But it still with same problem:

@paulocoutinhox it needs to be added here as well


You are correct, sorry, my mistake.

After add it to macos too, the problem persists:

@paulocoutinhox sorry about that, I patched the uploader and it should propagate in about an hour or two be live.


I have uploaded again, but still the same.

@paulocoutinhox, hmmm it looks like it’s still picking up 0.3.0 instead of 0.3.1 here. Let me check tomorrow why that might be happening.

@paulocoutinhox ok, the new version should have been pushed. Sorry about that again, I should have checked myself.

No problem tom, relax.

I still need that flag?

@paulocoutinhox yes, you’ll need the flag still (and going forward). You can push a commit up now.

hi @tom it is 100% now.

thanks for your time and help :slight_smile:

1 Like