Code coverage Report failure

Description

I’m building my C++ code on Travis :https://travis-ci.org/github/Axel13fr/lib_sonarcov
I tried the suggested fixes but I still get There was an error processing coverage reports.

My coverage.info file looks good to me (https://travis-ci.org/github/Axel13fr/lib_sonarcov/jobs/675809716#L2656) and I’ve tried the directory fixes (https://github.com/Axel13fr/lib_sonarcov/blob/master/codecov.yml) but still no luck…

Repository

Versions

Ubuntu 16.04 & Ubuntu 18.04 on the travis build.

So I’ve got finally a working version with the help of someone else by using the codecov python instead of the bash script.
But the latest codecov version (2.0.22) doesn’t work for my case and I had to use version 2.0.15.

Anybody has an idea of that difference or how I could get more debug infos on this ?

Hi @Axel13fr, sorry for the long wait, and I’m sorry that you were getting the issue with processing coverage reports. I see that you’ve been able to get some luck with the python uploader.

Unfortunately, the commit is too old for me to pull up logs for what might have happened. If you are happy with this, I’m happy to close this out. If not, we still do recommend the bash uploader, and I’d be happy to work with you to get it fixed.