Codecov Badge Unknown (for me only) on GitHub

@ thomasrockhu kindly pointed me here from my GitHub Issue

Strangely, my codecov badge appears unknown only to me as:

  • @ thomasrockhu could see my coverage percentage
  • I can see it in my local dev environment

Any ideas?

@rdmolony, thanks for posting here! Could you screenshot what you are seeing with a URL?

Of course

Thanks @tom for your help!

@rdmolony, I have to imagine this is a caching issue on your browser. I have tried many ways to get the unknown badge, but it doesn’t seem to hit. Can you try clearing your browser cache if it still isn’t showing now?

Thanks @tom! I cleared my cached web content & cookies and site data and still no luck…

(I’m uploading in multiple posts as new users can only post one image per post)

However, it does work on Chrome

Sorry I can’t be of more help to reproduce

@rdmolony this is really weird. What happens if you open the badge directly? Or if you go to the repository on a private window?

I get linked to the relevant dashboard:

Same result in a private window

Clicking on your badge link above leads me to

@rdmolony, I have a very strong suspicion this has to do with GitHub invalidating its cache. We did some work on our end to invalidate more quickly, but I think there are still a few badges stuck in a weird state. Are you able to see a value now and is it the correct value?

Still stuck on unknown! Not such a big deal if (as seems to be the case) that this bug is just on Firefox & just on my laptop. Cheers @tom

Bizarre… I’ll ping back here if we find anything else, but let me know if it switches from unknown

Sure thing :slightly_smiling_face:

We’re good!

Cheers @Tom

1 Like