Badge broken after changing github repo name

Description

My codecov integration through travis seemed to be working well until I changed the name of my git repository. The codecov page (linked below) still seems to be running fine, and showing me updated information, but the badge gives an ‘unknown’ status.

On the github side, it says everything is enabled for codecov webhooks.

On the codecov side, it’s telling me:

GitHub Integration is installed. However, this repository is not enabled.

  1. Click here to your installation listings
  2. Find Repository access and add kalepy to the list.

And when I check the linked webpage, I get a 404 not found error.

I tried deleting and resetting the webhooks, but no change. Any advice would be appreciated.

Thanks!

Repository


3 days later the badge has started working… no idea what happened.
Mods: feel free to delete post

Sorry you had issues, but I’m glad it worked itself out.

We will keep this post around, because it may be helpful for others. I’m sure caching of your repository settings was at play here.

We can dig around looking for the particular cause of the issue in our code, but it may be helpful for future sufferers of this problem to know that eventually this issue will likely correct itself.