Codecov Badge shows unknown

Before submitting a topic, please confirm the following

I have searched for similar issues before creating this topic.
I have verified that my repository is using the Codecov GitHub app, if using GitHub
I have validated my codecov.yaml configuration file.
I have filled out the below sections to the best of my ability.
I understand that the community boards are a free, best-effort tool. While we hope to have someone on the Codecov team resolve your problem quickly, this is not always possible.


Codecov badge is not showing on my repo and others. I have not found recent reports of this so I am posting to see if others are facing the same issue.


Please provide a link to the CI/CD run.

Codecov Output

Please provide the full output of running the uploader on your CI/CD. This will typically have the Codecov logo as ASCII.

     _____          _
    / ____|        | |
   | |     ___   __| | ___  ___ _____   __
   | |    / _ \ / _` |/ _ \/ __/ _ \ \ / /
   | |___| (_) | (_| |  __/ (_| (_) \ V /
    \_____\___/ \__,_|\___|\___\___/ \_/

  Codecov report uploader 0.3.5
[2023-03-01T00:17:52.476Z] ['info'] => Project root located at: /home/runner/work/slideshow-react/slideshow-react
[2023-03-01T00:17:52.478Z] ['info'] -> No token specified or token is empty
[2023-03-01T00:17:52.486Z] ['info'] Searching for coverage files...
[2023-03-01T00:17:52.557Z] ['info'] Warning: Some files located via search were excluded from upload.
[2023-03-01T00:17:52.558Z] ['info'] If Codecov did not locate your files, please review
[2023-03-01T00:17:52.558Z] ['info'] => Found 1 possible coverage files:
[2023-03-01T00:17:52.559Z] ['info'] Processing /home/runner/work/slideshow-react/slideshow-react/coverage/storybook/coverage-storybook.json...
[2023-03-01T00:17:52.564Z] ['info'] Detected GitHub Actions as the CI provider.
[2023-03-01T00:17:52.566Z] ['info'] Pinging Codecov:*******&branch=main&build=4298625511&
[2023-03-01T00:17:53.146Z] ['info']
[2023-03-01T00:17:53.147Z] ['info'] Uploading...
[2023-03-01T00:17:53.389Z] ['info'] {"status":"success","resultURL":""}

Expected Results

Please provide what you expect to have happened (e.g. a file that has missing coverage on a particular line).
The badge should show with the given code coverage.

Actual Results

Please provide what actually happened.
The badge shows up as unknown.

Additional Information

Example repos:
(my repo) GitHub - kaceycleveland/slideshow-react
another one: GitHub - codecov/typescript-standard: Codecov coverage standard for TypeScript


Yep, I’m facing the same issue. I think I saw it working yesterday but I’m not completely sure.

Repo: GitHub - webbertakken/email-worker: Lightweight tool to process emails directly from Cloudflare
Codecov: Codecov

Facing the same issue here. Not only my own repository but also other repositories that I visit often.
See e.g.,

I have the same issue, has anyone solved this yet?

Seems like many repositories are affected.
I’ve created a support ticket to alert the team and draw attention to this thread.

same here… GitHub - raphaelquast/EOmaps: A library to create interactive maps of geographical datasets

using works just fine ( Quality metadata badges for open source projects)

After digging a bit further I noticed that there seems to be something wrong if an explicit branch is specified for github projects… e.g:

but this gives an “unknown” badge (I can’t add 2 images to a single post so you can’t see it :sweat_smile:)

Same issue here:

Same here; Two of my reposiotries are affected

Seems like removing branch/foo from the url works!
before →
after →

My ticket got resolved. Looks like they solved it for all repos. :tada:

Sorry all, didn’t see this. This should now be fixed for all repos.