Codecov + private repo on getting CI Failed

Before submitting a topic, please confirm the following

I have searched for similar issues before creating this topic.
I have verified that my repository is using the Codecov GitHub app, if using GitHub
I have validated my codecov.yaml configuration file.
I have filled out the below sections to the best of my ability.


Submitted a Jest coverage report to Codecov on Gitlab-CI in a private repository hosted at
Gitllab-CI run was successful and coverage submission to Codecov was successful. The display in Codecov is “CI Failed” and the commit message is “commit message unavailable”. I don’t think this is normal.


Please provide a link to the CI/CD run.

Codecov Output

Please provide the full output of running the uploader on your CI/CD. This will typically have the Codecov logo as ASCII.

$ ./codecov -t ${CODECOV_TOKEN} -v
[2022-08-05T05:42:10.792Z] ['verbose'] Start of uploader: 1659678130791...
[2022-08-05T05:42:10.794Z] ['info'] 
     _____          _
    / ____|        | |
   | |     ___   __| | ___  ___ _____   __
   | |    / _ \ / _` |/ _ \/ __/ _ \ \ / /
   | |___| (_) | (_| |  __/ (_| (_) \ V /
    \_____\___/ \__,_|\___|\___\___/ \_/
  Codecov report uploader 0.2.5
[2022-08-05T05:42:10.847Z] ['info'] => Project root located at: /builds/xxxxxxxx/********/********
[2022-08-05T05:42:10.849Z] ['info'] ->  Token found by arguments
[2022-08-05T05:42:10.850Z] ['verbose'] Start of network processing...
[2022-08-05T05:42:10.851Z] ['verbose'] Searching for files in /builds/xxxxxxxx/********/********
[2022-08-05T05:42:10.863Z] ['verbose'] coveragepy is not installed
[2022-08-05T05:42:10.863Z] ['info'] Searching for coverage files...
[2022-08-05T05:42:11.961Z] ['info'] Warning: Some files located via search were excluded from upload.
[2022-08-05T05:42:11.962Z] ['info'] If Codecov did not locate your files, please review
[2022-08-05T05:42:11.962Z] ['verbose'] Preparing to clean the following coverage paths: coverage/clover.xml,coverage/
[2022-08-05T05:42:11.962Z] ['info'] => Found 2 possible coverage files:
[2022-08-05T05:42:11.962Z] ['verbose'] End of network processing
[2022-08-05T05:42:11.963Z] ['info'] Processing  /builds/xxxxxxxx/********/********/coverage/clover.xml...
[2022-08-05T05:42:11.965Z] ['info'] Processing /builds/xxxxxxxx/********/********/coverage/
[2022-08-05T05:42:11.973Z] ['info'] Detected GitLab CI as the CI provider.
[2022-08-05T05:42:11.973Z] ['verbose'] -> Using the following env variables:
[2022-08-05T05:42:11.973Z] ['verbose']      CI_BUILD_ID: 2817765495
[2022-08-05T05:42:11.973Z] ['verbose']      CI_BUILD_REF: 6f220a4c60f5b59af4a574996e51dc7b560daa6e
[2022-08-05T05:42:11.974Z] ['verbose']      CI_BUILD_REF_NAME: develop
[2022-08-05T05:42:11.974Z] ['verbose']      CI_BUILD_REPO: undefined
[2022-08-05T05:42:11.974Z] ['verbose']      CI_COMMIT_REF_NAME: develop
[2022-08-05T05:42:11.974Z] ['verbose']      CI_COMMIT_SHA: 6f220a4c60f5b59af4a574996e51dc7b560daa6e
[2022-08-05T05:42:11.974Z] ['verbose']      CI_JOB_ID: 2817765495
[2022-08-05T05:42:11.974Z] ['verbose']      CI_MERGE_REQUEST_SOURCE_BRANCH_SHA: undefined
[2022-08-05T05:42:11.974Z] ['verbose']      CI_PROJECT_PATH: xxxxxxxx/********/********
[2022-08-05T05:42:11.975Z] ['verbose']      CI_REPOSITORY_URL: https://gitlab-ci-token:[MASKED]********/********.git
[2022-08-05T05:42:11.975Z] ['verbose']      GITLAB_CI: true
[2022-08-05T05:42:11.975Z] ['verbose'] Using the following upload parameters:
[2022-08-05T05:42:11.975Z] ['verbose'] branch
[2022-08-05T05:42:11.975Z] ['verbose'] build
[2022-08-05T05:42:11.975Z] ['verbose'] buildURL
[2022-08-05T05:42:11.975Z] ['verbose'] commit
[2022-08-05T05:42:11.976Z] ['verbose'] job
[2022-08-05T05:42:11.976Z] ['verbose'] pr
[2022-08-05T05:42:11.976Z] ['verbose'] service
[2022-08-05T05:42:11.976Z] ['verbose'] slug
[2022-08-05T05:42:11.976Z] ['verbose'] name
[2022-08-05T05:42:11.976Z] ['verbose'] tag
[2022-08-05T05:42:11.977Z] ['verbose'] flags
[2022-08-05T05:42:11.977Z] ['verbose'] parent
[2022-08-05T05:42:11.978Z] ['info'] Pinging Codecov:*******&branch=develop&build=2817765495&build_url=&commit=6f220a4c60f5b59af4a574996e51dc7b560daa6e&job=&pr=&service=gitlab&slug=xxxxxxxx%2F********%2F********&name=&tag=&flags=&parent=
[2022-08-05T05:42:11.978Z] ['verbose'] Passed token was 36 characters long
[2022-08-05T05:42:11.979Z] ['verbose']********%2F********&name=&tag=&flags=&parent=
        Content-Type: 'text/plain'
        Content-Encoding: 'gzip'
        X-Reduced-Redundancy: 'false'
[2022-08-05T05:42:12.435Z] ['info']********/********/commit/6f220a4c60f5b59af4a574996e51dc7b560daa6e
[2022-08-05T05:42:12.435Z] ['verbose'] Returned upload url:
[2022-08-05T05:42:12.435Z] ['info'] Uploading...
[2022-08-05T05:42:12.840Z] ['info'] {"status":"success","resultURL":"********/********/commit/6f220a4c60f5b59af4a574996e51dc7b560daa6e"}
[2022-08-05T05:42:12.840Z] ['verbose'] End of uploader: 2049 milliseconds

Expected Results

Actual Results

Additional Information

Hi @yabukane we pushed a fix around GitLab log ins, are you still getting the issue? I think we still have a bug where we show CI Failed until we have finished processing reports. Do older commits still show up as failed when they shouldn’t?

Thanks for reply.
Unfortunately it doesn’t seem to change to me.

GitLab’s CI reports success.
(I can’t attach an image from GitLabCI due to forum restrictions, but it shows success)

Since this repository is a private repository used within the organization,
I can’t publish it for contributions, but is there anything I can check to resolve it?

@yabukane I’d probably need a recent commit SHA to dig in further. Can you check that the team bot is set properly?

wonderful! worked perfectly.

I followed the instructions and set my username in the global YAML configuration.
But the situation does not improve.
I guessed that the set YAML was not reflected correctly, so I deleted the data of the corresponding repository from CodeCov, disabled it, and enabled it again.
Ran it again and it worked correctly.
Commit comments were also fetched correctly and the CI state is now Passed.

1 Like

@yabukane glad that it was an easier fix!

1 Like


I have identical situation:

Gitlab with a private repo that belongs to my company’s organisation.
I have added one of the repos to codecov logged in with my gitlab user.
In the past I was running without the codecov.yml file.
Now I added it and specified bot: my-user-name-in-gitlab.
I can see it is recognised in yaml in settings.
But still codecov shows commit message unavalable and ci failed and will not post to my MRs.
I tried deleting all data , deactivating and activating again - no change.

It still shows Team bot is missing

Any help would be really appreciated.

If it helps, newest commit sha on master: 7ad9ccc95c3994347058b78fd20fa8d0e66899f0



I have figured this out.

Looks like Codecov’s documentation could get a slightly better wording, it says to add the bot in team yaml , it did not click with me what this means. I thought that having it in the project in the file is enough.

Could we say instead of team yaml call it your organisation global yaml ?

1 Like