CodeCov Uploads from Azure Pipelines are failing with 'Build numbers do not match'

Hi everyone, we’ve identified the root cause and will be working on a fix.

2 Likes

Hi @johlju, sorry for the delay on this. We are trying to test out a fix, would you by chance have a recent commit where you are still seeing this issue?

@tom I pushed a new commit to the PR https://github.com/dsccommunity/xFailOverCluster/pull/242

Still fails on the run here https://dev.azure.com/dsccommunity/xFailOverCluster/_build/results?buildId=2329&view=logs&j=9c98dabf-a506-5435-4ead-dace7c1625a8&t=c251aece-c156-5cd3-dcec-645d5e596fc0

Hi @johlju, we made another fix that should fix the issue. Would you mind pushing a new commit and seeing if you are getting the issue?

Looks like it is fixed now! Big thanks for finding the issue and resolving it! :smiley:

Uploaded correctly here:
https://dev.azure.com/dsccommunity/xFailOverCluster/_build/results?buildId=2429&view=logs&j=9c98dabf-a506-5435-4ead-dace7c1625a8&t=c251aece-c156-5cd3-dcec-645d5e596fc0

It does say “curl: (3) malformed” in the logs but that might be expected.

The PR comment was added:

1 Like

It does say “curl: (3) malformed” in the logs but that might be expected.

Yes, this is an issue we are working to fix, but it in innocuous right now. Thanks for letting me know!

I just got the same issue again today. I merged a PR into the branch and then when the branch builtt the same error was thrown.

The PR build successfully uploaded the coverage
https://dev.azure.com/dsccommunity/SqlServerDsc/_build/results?buildId=2565&view=logs&j=9c98dabf-a506-5435-4ead-dace7c1625a8&t=c251aece-c156-5cd3-dcec-645d5e596fc0

But the branch failed to upload coverage:
https://dev.azure.com/dsccommunity/SqlServerDsc/_build/results?buildId=2568&view=logs&j=9c98dabf-a506-5435-4ead-dace7c1625a8&t=c251aece-c156-5cd3-dcec-645d5e596fc0

Hi @johlju, thanks for that data. We will be making some changes to our backend to track these errors better. Until then, if you are able to comment with any additional builds that fail in the future, it would be most helpful.

This build fails the same way when a PR was merged to the branch:
https://dev.azure.com/dsccommunity/SqlServerDsc/_build/results?buildId=2657&view=logs&j=9c98dabf-a506-5435-4ead-dace7c1625a8&t=c251aece-c156-5cd3-dcec-645d5e596fc0

But the actual PR successfully uploaded the report:
https://dev.azure.com/dsccommunity/SqlServerDsc/_build/results?buildId=2652&view=logs&j=9c98dabf-a506-5435-4ead-dace7c1625a8&t=c251aece-c156-5cd3-dcec-645d5e596fc0

I can always create a PR in above repo if you make a change to this and need a to test upload coverage for this scenario.

Let me know when you want me to test again. I’m adding back the token as a temporary workaround so the repo (dsccommunity/SqlServerDsc) can upload coverage reports, otherwise the coverage reports in PRs gets messed up (not showing the correct diff).

Hi @johlju, if you don’t mind, we’d love to test this again. We’ve added some logging on our end and would like to see why this isn’t working for you.

I run the the pipeline manually on the branch and it failed to upload coverage.
https://dev.azure.com/dsccommunity/SqlServerDsc/_build/results?buildId=2821&view=logs&j=9c98dabf-a506-5435-4ead-dace7c1625a8&t=c251aece-c156-5cd3-dcec-645d5e596fc0

Here is a new PR that uploaded the coverage correctly.
https://dev.azure.com/dsccommunity/SqlServerDsc/_build/results?buildId=2822&view=logs&j=9c98dabf-a506-5435-4ead-dace7c1625a8&t=c251aece-c156-5cd3-dcec-645d5e596fc0

And here it is failing when PR was merged to the branch:
https://dev.azure.com/dsccommunity/SqlServerDsc/_build/results?buildId=2825&view=logs&j=9c98dabf-a506-5435-4ead-dace7c1625a8&t=c251aece-c156-5cd3-dcec-645d5e596fc0

This is fantastic, thank you @johlju!

No problem. Happy to help so we can resolve this. :slight_smile:

Here is another one:

PR upload coverage:
https://dev.azure.com/dsccommunity/SqlServerDsc/_build/results?buildId=2836&view=logs&j=9c98dabf-a506-5435-4ead-dace7c1625a8&t=c251aece-c156-5cd3-dcec-645d5e596fc0

But failed when uploading from the branch (when PR was merged):
https://dev.azure.com/dsccommunity/SqlServerDsc/_build/results?buildId=2837&view=logs&j=9c98dabf-a506-5435-4ead-dace7c1625a8&t=c251aece-c156-5cd3-dcec-645d5e596fc0

I will add back the token as a temporary workaround. Let me know when you need to test again. :slight_smile:

Hi @johlju, just an update that we are still taking a look at this. We’ve found the root cause and we’ll be working on figuring out a fix. Thanks for your patience here.

1 Like

Hi @johlju, apologies for the delays here. We’ve made some changes that should fix this. Let me know if you would be able to test again.

Still seeing the issue unfortunately.

Coverage uploads in the PR build:

But still fails to upload coverage when the PR is merged and the branch is built:

Thanks here @johlju, I’ll dig again to see what happened.

Hi @johlju, we pushed a new fix for this, would you be able to see if it’s working for you now?

Sorry to say the error is still there. I today merged a PR to main branch and still got the error: