Coverage upload hanging until timeout

At some point codecov uploader simply hangs on the following:

  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  158k    0     0  100  158k      0   3688  0:00:43  0:00:43 --:--:--     0

That is, 100% upload progress with speed of 0. This is after discoering everything, and I believe after reporting someting to codecov already - I can see branch in codecov, bot no coverage at all.

This is using `bash -c “bash <(curl -s -v -t token

Any idea here? This fails in the same fashion both for me locally and from CI

Update: I did try out locally and it turns out this fails with macOS’s curl command. When installed curl from brew and setting it as main one, upload succeeds

Hi @wasyl

Glad you got it working. Not sure sure why MacOS’s curl wouldn’t work, I wonder if it has to do with the default shell being zsh in newer macs.

Does the workaround listing at the bottom here work?

It did not. I tried to specify one file using -f, and I tried different variations of the script, including that one you linked.

I wonder if others have the same issue. And I do use zsh btw

Huh. I’ll try to determine what difference there may be between the MacOS curl and the homebrew one, but I have a bunch on my plate and don’t want to give a timeline expectation.

If you have a dummy commit you can try to upload with the MacOS curl, and share the SHA, that would enable me to look and see if it does hit our servers in any form.

Unfortunately I can’t invest too much time right now either. Perhaps someone will encounter this too and investigate further

1 Like

I’m also experiencing this issue on Github Actions with macOS, see the logs.

@menelike thanks for the info and workaround!

FYI y’all, we’ve updated our certs and system is back up.

Thanks @menelike for the interim workaround!