Error 500 when accessing settings of Bitbucket repository


When trying to access my repository (which is hosed on Bitbucket), I get a HTTP 500 error.

Commit SHAs

The last coverage commit was 54f4e2a5c16ab396422d5590fe5115c4c010a38c.


The repository is:

CI/CD or Build URL

Build is done from Bitbucket pipelines:!/results/24


The bash uploader is being used. The most recent upload exited successfully.

Codecov Output

`                              Bash-20201130-cc6d3fe`



`==> Bitbucket detected.`

`    project root: .`

`--> token set from env`

`    Yaml not found, that's ok! Learn more at`

`==> Running gcov in . (disable via -X gcov)`

`==> Searching for coverage reports in:`

`    + .`

`    -> Found 1 reports`

`==> Detecting git/mercurial file structure`

`==> Reading reports`

`    + ./coverage.xml bytes=71895`

`==> Appending adjustments`


`    + Found adjustments`

`==> Gzipping contents`

`        8.0K	/tmp/codecov.kJPjE1.gz`

`==> Uploading reports`

`    url:`

`    query: branch=master&commit=54f4e2a5c16ab396422d5590fe5115c4c010a38c&build=24&build_url=&name=&tag=&slug=Roberto-R%2Fuptime-tester&service=bitbucket&flags=&pr=&job=24&cmd_args=`

`->  Pinging Codecov`


`->  Uploading to`


`  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current`

`                                 Dload  Upload   Total   Spent    Left  Speed`


`  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0`

`100  7469    0     0  100  7469      0  42437 --:--:-- --:--:-- --:--:-- 42437`

`    -> View reports at`

Expected Results

Expected to view the repository settings.

Actual Results

Received HTTP 500 error page.

Additional Information

@RobertoRoos, are you trying to view this URL or

What happens if you do not log in and view it on a private browsing session/incognito?

Both those URLs work. But if I access the repository main page and go to the settings tab (so I am met with the 500 error.

The same happens from incognito mode.

I tried to link a repository in a new Bitbucket account to and I ran into the same issue there.

@RobertoRoos, can you try clearing your cookies, logging out, and logging back in again?

Tried it, but no changes.
I also logged in from a private window, still the 500 error.

Note that I also cannot view Commits, Branches and Pulls windows. They all give the same 500 error.

EDIT: Interesting, I can view the commits page from an incognito window (, but I cannot after I’ve logged in.

Error still persists, but I found out I can circumvent it by going directly to the settings/badge page:

From the settings/badge page, I can click on the sidebar link to go to settings/general. So I’ve managed to extract my token, badge URL and re-create the webhook.

Not much as a solution I guess, but a workaround.

Just wanted to confirm the issue still persists.

And I found that on another account one Bitbucket repo works perfectly, while another shows the familiar problem:

This repo will give an error when for example going to the ‘Commits’ tab:

Whereas this one works:
(You will get an 400 unauthorized error, instead of a 500 error. When I’m logged in it work normally.)

Maybe the Codecov team can figure what the difference is between the repos?

Hi @RobertoRoos, apologies, I had meant to update this thread that we are investigating from our side. Thank you so much for the extra data there.

Hi @RobertoRoos, would you be able to see if you still run into the issue? We have deployed a fix here.

Thank you for getting back at this.

I can view my project normally (at, and I can view the Commits, Branches, Pulls and Compare tabs. On the Settings tab however, I now get an “Unauthorized” error:

(Yes, I am admin of that BB repo.)

Still, if I go to a settings URL directly (without the ‘app’ subdomain) I can view the settings:

So a partial improvement?

Note that I am also denied access to private repos of other teams in Codecov I do have access to in Bitbucket.

@RobertoRoos, got it. I’ll bring this up with the product team. Thanks for the update.

@RobertoRoos we made a few fixes here, is this still an issue for you?

Yes, that’s fixed it! All the pages can now be viewed normally!

Thank you and your team for your work.

1 Like