Error sending coverage report

Description

Hey,

We have issues during uploading coverage reports.

HTTP 400
Provided token is not a UUID or global upload token.

However token is provided from repository settings.

Issue can be related to fact that our GitHub repository is private and connected to organization inside git hub but we granted all required access and repository appears in the list available repos.

Repository

https://codecov.io/gh/kenshoo/social

Welcome @mmarusich

Are you using the bash uploader, also which CI are you using?

Hey @eddiemoore ,

We are using Jenkins and yes we use bash uploader.

Script we executing:

16:41:12 + curl -s https://codecov.collibra.com/bash 16:41:12 + bash -s – -c -F aFlag -f target/site/jacoco-aggregate/jacoco.xml

16:41:12 ==> Jenkins CI detected. 16:41:12 project root: . 16:41:12 Yaml found at: codecov.yml 16:41:12 --> token set from yaml 16:41:12 -> Found 1 reports 16:41:12 ==> Detecting git/mercurial file structure 16:41:12 ==> Reading reports 16:41:12 + target/site/jacoco-aggregate/jacoco.xml bytes=5616590 16:41:12 ==> Appending adjustments 16:41:12 http://docs.codecov.io/docs/fixing-reports 16:41:16 + Found adjustments 16:41:16 ==> Gzipping contents 16:41:16 ==> Uploading reports 16:41:16 url: https://codecov.collibra.com 16:41:16 query: branch=origin%2Fadd_codecov_settings&commit=c3605ab655da50ce982d89a5267aaabe3c918cc0&build=16&build_url=https%3A%2F%2Fjenkins.klocdev.info%2Fjob%2Fsocial_master_coverage_report%2F16%2F&name=&tag=&slug=kenshoo%2Fsocial&service=jenkins&flags=aFlag&pr=&job= 16:41:16 -> Pinging Codecov 16:41:16 https://codecov.collibra.com/upload/v4?package=bash-8a28df4&token=<removed_for_security_reasons>&branch=origin%2Fadd_codecov_settings&commit=c3605ab655da50ce982d89a5267aaabe3c918cc0&build=16&build_url=https%3A%2F%2Fjenkins.klocdev.info%2Fjob%2Fsocial_master_coverage_report%2F16%2F&name=&tag=&slug=kenshoo%2Fsocial&service=jenkins&flags=aFlag&pr=&job=

16:41:17 HTTP 400 16:41:17 Provided token is not a UUID or global upload token.

This what we get, I removed token value for security reasons, but it uses correct value taken from repository settings

Can you try passing it via -t <TOKEN> to the bash upload script?

Something like:
bash -s – -c -F aFlag -t <TOKEN> -f target/site/jacoco-aggregate/jacoco.xml

@eddiemoore Tried such way but still no luck, getting same error

@tom Can you have a look and see what is happening here

Thanks for bringing this up @eddiemoore , just FYI Eli is taking a look offline as some details can’t be shared publicly for a private repo. Will share the fix here after it’s resolved!

1 Like

Remark for @mmarusich
I see you are targetting codecov.collibra.com, why using that specific host and not the default mentioned in docs (https://docs.codecov.io/docs/about-the-codecov-bash-uploader) ?

16:41:12 + curl -s https://codecov.collibra.com/bash 16:41:12 + bash -s – -c -F aFlag -f target/site/jacoco-aggregate/jacoco.xml

1 Like

Hey,

Not sure why I used it, seams copy pasted from wrong place. Checking with link from docs, will update regarding results

Thanks for pointing to this :slight_smile:

1 Like

It works, thanks for help with solving this issue

1 Like

You’re welcome x)
It seems also that a previous version of codecov docs did idd contain the mentioned url (codecov.collibra.com), if I refer to the cached version of the page in google at http://webcache.googleusercontent.com/search?q=cache:MiTWAtFQMcAJ:https://docs.codecov.io/docs/supported-ci-providers&hl=en&gl=be&strip=1&vwsrc=0.
Maybe someone at codecov could better know how this happened (c/c after a conversion with someone at collibra ?). @hootener ?

Anyway I’m happy if this helped ^^

@MorganGeek @mmarusich sorry guys! Jerrod here. This was my fault totally. Updated docs as soon as we caught it.

1 Like