File paths not correct but correct in report


Thes files where there is coverage are all under src/bin/ but too often they are shown as under sbin/.
The interface becomes moot this it can no longer find the files when I want to review them.
I’ve tried applying fixes for that but it does not help.
I’ve looked at the output from codecov and there the path is correct.





bash uploaded

Commit SHAs


Codecov YAML

  - "../::"
  - "/terminology/::"

Codecov Output

Steps to Reproduce

  1. Go to
  2. The files listed are under sbin/ while this directory does not exist. Should be src/bin/

Expected behavior:
Files are correctly listed under src/bin

Actual behavior:
Files are listed under sbin/

This does not occur all the time.

Additional Information

My guess is that this is related to some issue with the integration with github.
It is to be noted that src/ has only one child which is bin/. When looking into it on github, one can see that it is displayed as src/bin.

Those 2 commits are on the same untracked file but one show the wrong behavior while the other does not:

The commit where I played with fixes with no luck: (actually it went fine on that commit).

Hi @billiob, sorry for the delay. This took us awhile to figure out, but basically the "../::" in your fixes is causing issues as it is being used as a regex in our system in some cases. We haven’t been able to completely determine what cases those are, but are you able to remove it from the fixes?

Hi @tom,
Thanks for your answer.

Here’s my setup:
repository is cloned in /terminology/
There, a build/ directory is created and binaries are generated there. Tests are run there too.
codecov is also run from there.

In codecov’s report, here what I see:

 # path=build/^#src#bin#sb.c.gcov.reduced
        -:    0:Source:../src/bin/sb.c

I’ve tried to run codecov directly from the root of the repository and removing the fixes (the whole .codecov.yml) but it outputs these kind of messages:

Cannot open source file ../src/bin/tycommon.c
Cannot open source file ../src/bin/tycat.c

It is on that commit:
On it, codecov fails on processing the report: but I don’t know why.

Hi @billiob, apologies, I think the terminology/:: part is fine, it was the previous line. Would you be able to run with that as a fix?

This seems to have fixed it!

1 Like