Pathfixing question

Hi,

Sorry if I’m dense here :slight_smile:

I am having trouble to see the reports and files linked to my github repo.

In my coverage.xml the path seems to be.

<sources>
	<source>/usr/src/app</source>
</sources>
<packages>
	<package name="app" line-rate="0.6226" branch-rate="0" complexity="0">
		<classes>
			<class name="__init__.py" filename="app/__init__.py" complexity="0" line-rate="1" branch-rate="1">
				<methods/>
				<lines/>
			</class>
			<class name="config.py" filename="app/config.py" complexity="0" line-rate="0.875" branch-rate="1">
				<methods/>
				<lines>

etc

But at github the root is:

project/<source>

I tried (a lot of different settings), but from the docs I thought that this was correct.

fixes:
- "project/::"  # move path   e.g., "before/path" => "after/path"

Is there any way to debug this and see what’s missing.

(the repo in question is GitHub - falkowich/sorta-simple-fastapi-template: My try to create a working boilerplate for myself when l)

[edit]
I run codecov manually for this tests
[/edit]


Regards Falk

@falkowich, I don’t actually think you need to do path fixing. The issue with your latest reports is actually around expiration. Would you try adding

codecov:
  max_report_age: off

If you think path fixing is still the solution, what are you seeing that isn’t quite matching up?

Hi,

I am absolutely not sure of this :slight_smile:

But it seems that codecov and github isn’t really agreeing where the files are located.

Here is a gif to show what I mean.

Peek 2021-08-18 11-16

Does it make any sense?


Regards Falk

@falkowich definitely, I saw that too. But it looks like things SHOULD be able to work without path fixing. And adding project/:: is actually messing things up. Path fixing is complicated, so I could be totally wrong, but I would remove it first. Let me know if that still isn’t working for you.

@tom, I removed the “fixing” in codecov.yml.
But sadly still the same problem for me.

Any ideas?


Regards Falk

@falkowich, sorry you will also need to add

codecov:
  max_report_age: off

to the codecov.yml

@tom, That is now done.
But no cigar :slight_smile:


Regards Falk

@falkowich this is strange, I just tried on my side and it is working. I will say there is a bug in the dashboard on some folders that are being interpreted as files, but I can click into the majority of files. Can you show me another gif of this happening to you?

@tom

wh00t, suddenly everything seems to work! :smiley:
Dunno what have changed, but I’m happy with this outcome :slight_smile:


Regards Falk

1 Like