GitLab repos are not listed after logging in with GitLab credentials


When I login to codecov using my GitLab credentials, I see a list of the organizations I’m apart of as well as my own personal account. However, when I click the “Add a repository” button at the bottom of organization card, I get an empty list, despite the fact that there are multiple GitLab repos under that organization. Navigating directly to the expected URL for the codecov page for a given repo gives a 404. Perhaps there is some permission I need to enable on the GitLab side to allow codecov to see the list of my repositories?


I’ve tried with other repositories, both under organizations that I’m a part of as well as those that I own directly. None of them show up.

Steps to Reproduce

  1. Log in to codecov with GitLab credentials
  2. Brought to the dashboard with the list of organizations I belong to
  3. Click on add repository for the desired organization, but the list is empty. Navigating directly to the repo page ( gives me a 404

Expected behavior: To see a list of the GitLab repositories under each group to which I belong and be able to add codecov to them.

Actual behavior: No repositories are listed under the GitLab organizations

Flakiness? This happens all the time.


Browser: Chrome Version 80.0.3987.163 (have also tried with Firefox with similar results)
OS: macOS 10.15.3

Hi @wtbarnes, thanks for bringing this to our attention. We have found the root cause and are working on a fix here.

Hi @wtbarnes, this should be fixed now.

Hi @tom, yes I’m now able to add the repo. Thanks!

1 Like