Cannot add new GitLab repository


As described here: GitLab commit retrieval and other issues

I can click on the (sub)group (group:subgroup), but then I see “Choose a new repository below” with nothing under it. Clicking on “Sync team repository list” shows a loading icon for 5-15 seconds, but then it disappears and it doesn’t display any repos. Loading leads to a 404 page.

I tried to clear cookies/browsing data & tried to use incognito in Chrome, but I get the same result.


My GitLab username is the same as my username here.

Please let me know if more information is needed.

Perhaps this issue is caused because my repo is in a subgroup?

@tom do you know what’s happening? Codecov is completely unusable.

Hi @christophebedard, sorry for the late reply. We are still digging into why this is happening. It shouldn’t be a subgroup issue, but I’ll get back to you when we know more.

Hi @christophebedard, just an update. We have isolated the problem and pushing a fix for this.

Hi @christophebedard, thanks for bearing with us here. This has been fixed and you can go to to view coverage.

1 Like

Thank you!

(+ some characters)

1 Like