Heatmap link broken


In the heatmap, the link generated that I want to view coverage decrease is Search/Filter.php

When I click the link, it takes me to the Files tab with an empty page (since i’m a new user I can’t post more than one screenshot :roll_eyes:).

If i manually click the Files tab it shows me File path not found. Did you mean one of the paths below and one option is lib/Search/Filter.php

There is no file Search/Filter.php in my source code, but there is a file lib/Search/Filter.php so why does the heatmap generate incorrect links?


A link to the repository in question (or private)

Private repo


Please provide which CI/CD you are using

Github actions


Please provide which uploader you are using and command used to run it. If you are not using the bash uploader, we recommend switching to it before opening an issue here.


Commit SHAs

Please include the commit SHA(s)

Codecov YAML

Please include the codecov.yml as code

Not using one

Codecov Output

Please provide the full output of running the uploader on your CI/CD

Additional Information

Any additional information, configuration or data that might be necessary to reproduce the issue.

Hi @toymachiner62 this is most likely a path fixing issue. My guess is you might need something like this in your codecov.yml

  - "::lib/"

Let me know if that fixes your issue.

I already merged that PR and I forgot this repo is public. Here’s the PR https://github.com/catalyticlabs/catalytic-sdk-php/pull/43

I tried to open another PR to check if your suggestion fixed it, but I had to make some code changes.

I have another PR in a different repo with the same behavior and your suggestion doesn’t seem to be fixing it, unless i’m doing something wrong.

Here’s a PR and if you click the Codecov report and click on the leftmost box clients/Instances.java you can see the empty Files tab. What should the fix be for this particular PR? (I won’t touch it until I hear back from you).

@toymachiner62 can you link me to the PR with the codecov.yml changes?

Sorry I forgot the link https://github.com/catalyticlabs/catalytic-sdk-java/pull/36

Hi @toymachiner62, I made a quick suggestion in your PR. I THINK that will fix it, but let me know either way.

I made the suggested change, but it didn’t seem to do anything.

@toymachiner62, looks like this is an issue on our side, I have made a request to our product team.

Thanks for letting me know. I’m going to merge this PR as is then. If you could let me know when it’s fixed on your end I can create a new PR and try again.

1 Like

@tom any update on this?

Hi @toymachiner62, we have not forgotten about this issue and still have it in our system. Thanks for checking back.

1 Like

Hi @toymachiner62, just an update that we are still taking a look at this. Thanks for your patience here.

Hi @toymachiner62, thanks again for your patience here. I haven’t forgotten about this issue, and it is still on our roadmap.

Hey @tom - any update on this? It’s been about 6 months.

Hi @toymachiner62, apologies on this. We are actually in the middle of re-vamping our UI and that entire page. This particular issue is expected to be resolved in that update. We expect this page to be pushed middle to end of Q1 next year. Thanks for your incredible patience on this issue.

1 Like