Processing error on report

Description

It looks like codecov processing for my repo broke when I moved CI from travis to gitlab.
All I get is a general “error” message: https://codecov.io/github/pymor/pymor/commit/91ff58f8c317461bb76d4b2d58d90134c6e2713d
Codecov docs mention that I should be able to download the logs for that process, but I do not see how.
The report uploading seems to work: https://zivgitlab.uni-muenster.de/pymor/pymor/-/jobs/155993 uploads the artefact from a previous step https://zivgitlab.uni-muenster.de/pymor/pymor/-/jobs/155987/artifacts/file/.coverage

Since codecov provides no actual error I guessed that the problem is related to the path mapping, but no dice with stripping the gitlab-ci project root: https://github.com/pymor/pymor/pull/686/commits/91ff58f8c317461bb76d4b2d58d90134c6e2713d

Can someone from codecov look into the actual error for me?

I’ve tried changing the path fixes, manually forcing project root and general CI settings, but still no success.

Anybody got any pointers for me?

I have the exact same problem when migrating from Travis to CircleCI.

Did you find a way to fix that? :slight_smile:

I’m having the same issue here… used to have a repo’ on my personnal account, when migrating it to an organization, reports cannot be displayed. Would be nice to get “some log” to understand what’s happenning.

Sent an email to support telling me I might get an answer from the community be it appears we’re in a dead end here…

1 Like

Nope. I’m still waiting for help.

So it’s been a month now since my original post, but I’m still hoping that someone from codecov will look into this issue.

There’s at least one somewhat similar unanswered post: There was an error processing coverage reports

We really need someone from codecov to look into the actual logs here I think.

1 Like

Having similar issues. It worked fine before for me. I’d love to see what went wrong so I can go fix it :confused:

@renefritze

I’m very sorry for the delay here. Can you get me a newer URL please? I can’t pull the logs from that far back. :frowning:

Sure thing. Thanks for looking into it.

Failed processing on codecov: https://codecov.io/gh/pymor/pymor/commit/9edf381e6c5c0c67f20e75cbf4232ab2758ff2ff

The jobs for submitting those coverage reports:



@renefritze It looks like you are sending us your .coverage file, which is unsupported. Can you try passing us your coverage.xml file instead?

Looks like this works now: https://codecov.io/gh/pymor/pymor/commit/9229f6a8907d839d3c3bdcedb82e858931cfe15a

Did codecov at some point understand the native .coverage file? I have no idea how this could’ve ever worked otherwise, since the xml reporting in the pytest-coverage plugin has to be manually enabled, and it has never been in our project, AFAICT.

Either way, proper failure messages either on uploading or processing would be great. Thanks for looking into this, @drazisil

We did push a revert to a change on path fixing this morning, which could have affected this. Glad to hear it’s working again.

I will make sure the request for the failure messages is shared with the product team.