Remove folders from the UI report


Hi, I am generating report for a C++14/Cmake project. Initially I missed to remove the lib folders in the report. I did that later but I still see libs and another unwanted folder in the UI. How can I remove them from showing up in the UI and keep only the src folder.




Chromium, Ubuntu 18.04

Additional Information

the command I am using now:
lcov --remove ‘/usr/*’ ‘project_repositoy/libs/’ ‘project_repositoy/tests/’ --output-file

the new reports looks ok now, but the UI is still showing project_repositoy/libs and project_repositoy/tests - from previous reports

Hi there! Have you checked out our Ignoring Paths feature for new coverage reports?

Or are you saying you want to retroactively remove these folders from showing up at all in the UI?

Hi, sorry for resurrecting this very old post but we are having the same issue. We have renamed a folder and did a bunch of refactoring inside so path mapping is not an option. Even if we set carry-over property to false the old directory shows up in the UI reports and skewing our overall coverage results quite a lot.

Is there a way to prune these old reports from the system?

Hi @BYK do you mind opening a new topic for this? It’s fairly old, and there are some details in the template that would be useful.

1 Like