Reports are broken, Unable to find commit in Gitlab

Description

I am getting a “Unable to find commit in Gitlab” message from the commits page, the reports appear to be getting stuck in “processing” forever, and attempting to load a specific report results in a “Unable to find report content in the storage archive.” message.

Repository

https://codecov.io/gl/asuran-rs/asuran/

Versions

Arch linux - up to date
Firefox - 74.0
Chrome - 80.0.3987.149

Additional information

This appears to have started last night.
I have done wonky stuff on the gitlab side since creating the repo on the codecov side, so I attempted deleting the repository from the codecov side and recreating it as a troubleshooting step.

I have verified the gitlab webhooks are working, and even recreated and re-verified for good measure.

1 Like

We have the same issue:

https://codecov.io/gl/vidaid/CryptVFS/commit/7520809798ebc1097159e7d1cad4e1afd208dd34

Tried “reset webhook”. No dice. I’m wondering if all of codecov isn’t working for gitlab, or just a few people.

Hi all, thanks for bringing this to our attention. I’ve opened a ticket with our product team to take a look.

Hi there. We have the same problem with our repository (https://gitlab.com/octopus-code/octopus). The timing of the problem coincides with the move of gitlab to Cloudflare. See:

Maybe that can help the codecov team to fix it?

Hi everyone, this is an issue we are seeing across multiple users, and we are updating here: GitLab commit retrieval and other issues

HI everyone, thanks for your patience here. We have merged a fix and looks like those repositories should be seeing commits again.