GitLab commit retrieval and other issues

GitLab users may be experiencing intermittent issues retrieving commits and other tasks. The Codecov team is actively monitoring the situation.

Please follow this thread or below for updates:

Hello,

just to let you know that in our case it’s not intermittent at all : we have completly lost codov reports for the last 9 days.

resetting the webhook did nothing.
The ci logs still report that the reports have been successfully uploaded but all the commits are
Unable to find commit in GitLab and processing the report in codecov.
We don’t get the codcov comment on gitlab MR for MR created since this issue started.

It’s been five days; any updates? I can’t add any GitLab repo.

Hi everyone, we’ve been interfacing with the team at GitLab to get this resolved as quickly as possible. We currently believe this has to do with the recent switch to Cloudflare (https://about.gitlab.com/blog/2020/01/16/gitlab-changes-to-cloudflare/) and are digging into solutions.

Unfortunately, we don’t have a workaround for this, but we will update as we get this fixed.

Hi everyone, unfortunately I don’t have any positive updates on this issue. We are still working with GitLab to investigate the underlying root cause and are working hard to get this fixed.

Thank you for your patience, and we hope to have a solution soon.

You can see progress on issue being discussed here: https://gitlab.com/gitlab-org/gitlab/-/issues/214412

Hi everyone, we have found the root cause and have pushed a fix. We will continue to monitor the situation.

I saw that the GitLab issue was closed and that apparently the problem should be resolved, but I still can’t add a GitLab repository.

I can click on the (sub)group (group:subgroup), but then I see “Choose a new repository below” with nothing under it. Clicking on “Sync team repository list” shows a loading icon for 5-15 seconds, but then it disappears and it doesn’t display any repos. Loading codecov.io/gl/group:subgroup/repo leads to a 404 page.

I tried to clear cookies/browsing data & tried to use incognito in Chrome, but I get the same result.

Hi @christophebedard, sorry you’re running into this issue. Can you please open a separate thread for this and specify what your GitLab group and repos are as well as username?

1 Like

@tom I opened a thread here: Cannot add new GitLab repository