Specific pull request report hanging/causing internal server error

Description

We’ve got a PR that seems to bring out some very specific issue. The status for the PR doesn’t update, the commit page (https://codecov.io/github/antismash/antismash/commit/7f6d66567fe2be4cd87997d7fbbf6c9a2b9c8e34) never changes from ‘Reports are queued for processing… Please review report with caution, it may change.’ , and the link for the PR (https://codecov.io/gh/antismash/antismash/pull/227) results in an internal server error suggesting the repo is private (and it isn’t).

All other PRs before and after this specific one have functioned as expected. We’ve tried uploading the coverage reports from multiple machines with different versions of the codecov uploader and the python coverage package and they’ve all reported success but viewing the results has the same issue. We’ve also tried over a period of a week to upload and rerun, with no change in the codecov behaviour.

The base commit has a report and other PRs on the same base commit have no issue, so I’m out of ideas when it comes to possible causes apart from something internal to codecov.

Possibly unrelated: the status page on codecov for PRs (https://codecov.io/gh/antismash/antismash/pulls) also has the indicators for success flipped for PR 227 and 229, if that’s of any use tracking down the issue. PR 229 has the correct status via github, but not on the pulls page.

Hi @SJShaw

I believe I know this issue here (it’s internal and prioritized to be fixed) but 7f6d66567fe2be4cd87997d7fbbf6c9a2b9c8e34 is too old to confirm in the logs. (I was on vacation)

Can you provide a newer comment SHA from the past 2-3 days that has this issue so I can take a look?

As I say in the title, It’s the only commit that’s caused the issue, everything else has functioned as expected.

I’ve just resubmitted the coverage. If that doesn’t trigger the analysis to happen again, let me know and I can try something else.

I haven’t heard that the resubmission didn’t help, so I’m assuming that you’ve got what you need. If that’s wrong, then tell me.

Report 69636971-8dbf-4fe9-a653-6f6423245b59 is expired

It looks like you will need to regenerate the report as well.

Fair enough. I’ve re-run the entire CI path just now to regenerate and update everything.

Edit: The 500 internal server error is still an issue, though the spinning endlessly on “processing” for the commit view has apparently been resolved since I initially reported this.

My apologies, I need a new commit pushed. This one is as I suspected and is corrupt.

We’ve fixed future commits, but pushing the same commit again won’t resolve this.

Thanks for fixing the issue.

1 Like