Unable to find report content in the storage archive

Just to be complete, the “waiting for status…” is from the GitHub integration:

But I get the same behavior as you describe on the Codecov website. I don’t think we can directly verify the S3 upload (the URL isn’t given), so the closest we can get is the page you started with describing, the “unable to find report…” page.

I’m guessing all the folks with problems are using codecov for free, open source projects? Codecov is clear that they support such projects on a “best effort” basis - but I guess they have less bandwidth for this recently.

I see, thanks for clarifying. The codecov integration is also enabled for my GH repo as you mentioned, but I didn’t see the checks in any of my PRs. Just uploaded report directly from CircleCI pipeline using the Codecov orb linked in OP.

Thank you for the reports, everyone. We are investigating this, since it doesn’t happen for everyone it’s being hard to track down. We are seeing that, for those of you it is affecting, that it’s happening very often, so I completely understand your frustration.

Couple of questions:

  • Did this ever work correctly for you, and if so, do you know roughly when it started happening?
  • Can you think of any changes you made around this time?

@drazisil This is my first time trying to use codecov on a personal project. I’ve seen it work great on other projects, but it hasn’t worked at all since I’ve tried integrating myself as described.

Some (hopefully) helpful debug info:

  • Codecov was added on a feature branch, not master
  • Codecov was added on a later commit, not the first one (4th commit on this PR)
  • My codecov report is generated with jest-junit
  • My codecov report is uploaded with codecov-circleci-orb successfully as reported in OP

Thanks, @hboylan

Those points shouldn’t matter, but thanks for bringing them up. Can you share a commit SHA you are getting this error on so I can check the logs and confirm this is the issue we are investigating?

EDIT: Actually, you said you installed Codecov to a non-master branch? That might matter. Can you explain how you did this, and would it be possible to move it to master to test if that changes anything?

First successful successful upload was commit fbe5c6b27311a1be9b94b058afcb141c8ff1464e

Related CircleCI job is here

Appreciate you taking the time to look into this @drazisil!

Ah, you mean that your first commit to Codecov was on a non-master branch?

Can confirm this commit is an instance of what we are investigating currently for this thread.

I don’t have more I can report other then it’s being actively investigated and I’ll update when I have one.


I actually traced the original codecov report upload farther back to 0c87af16aa3b415042cffafa676c3c7e9413935b on branch “circleci”.

It was this job from before I renamed it “test”

FWIW, I am in a very similar situation, evaluating codecov, first commit was on a non-master branch using CircleCI Orb, Example commit SHA: b7260d322f50f56b761f6d97a6c691205dd546f0

Very interesting.

Two more questions then (at an attempt to pattern match)

1: Did everyone start uploading to a non-default branch?
2: Is everyone using the orb?
2.5: Does this happen if you use the bash uploader?

Yes to all for me. Just tried the bash uploader and the report still cannot be found in codecov.

Drat. Thank you for trying.

Just got codecov to recognize my report for the very first time.

  1. Checkout master branch on local machine
  2. Generate jest coverage report
  3. Push commit to master branch
  4. Upload coverage report with bash uploader
  5. Report shows up in codecov
1 Like

Sadly this didn’t work for me…default branch in our repo is development, just pushed to it and uploaded a coverage report, but I receive the same message. In the default view where it lists “All recent commits” it says “Unable to find commit in Github”, SHA: 00a7a6c15c2ce37713e193b68ebe2c8008daad12

Edit: Also worth noting that if I go to codecov.io/gh/myOrg/myRepo/commits that all are listed as “Processing…”

This definitely sounds like the issue in this thread. We are actively investigating and I hope to have an update soon.


Hey all, thanks for your contributions and apologies for the issue.

We started an open issue tracker on this here: OPEN ISSUE INVESTIGATION: Report stuck in processing + Unable to find report content in storage archive

This is affecting about 1% of users. We are rapidly looking for a root cause fix or a workaround we can deliver to you all. More updates to come on the thread above.

1 Like

Hey everyone, update that we’ve found a workaround for affected users. See OPEN ISSUE INVESTIGATION: Report stuck in processing + Unable to find report content in storage archive for more details.

We will need you to send along your relevant Github/Gitlab/Bitbucket organization name to hello@codecov.io to include you in workaround.


i am also facing same error. using codecov for first time.

$ export CODECOV_TOKEN="my real token "
$ bash <(curl -s https://codecov.io/bash)

  _____          _
 / ____|        | |
| |     ___   __| | ___  ___ _____   __
| |    / _ \ / _` |/ _ \/ __/ _ \ \ / /
| |___| (_) | (_| |  __/ (_| (_) \ V /
 \_____\___/ \__,_|\___|\___\___/ \_/

==> git version 2.25.1 found
==> curl 7.68.0 (x86_64-pc-linux-gnu) libcurl/7.68.0 OpenSSL/1.1.1f zlib/1.2.11 brotli/1.0.7 libidn2/2.2.0 libpsl/0.21.0 (+libidn2/2.2.0) libssh/0.9.3/openssl/zlib nghttp2/1.40.0 librtmp/2.3
Release-Date: 2020-01-08
Protocols: dict file ftp ftps gopher http https imap imaps ldap ldaps pop3 pop3s rtmp rtsp scp sftp smb smbs smtp smtps telnet tftp 
Features: AsynchDNS brotli GSS-API HTTP2 HTTPS-proxy IDN IPv6 Kerberos Largefile libz NTLM NTLM_WB PSL SPNEGO SSL TLS-SRP UnixSockets
x> No CI provider detected.
    Testing inside Docker? http://docs.codecov.io/docs/testing-with-docker
    Testing with Tox? https://docs.codecov.io/docs/python#section-testing-with-tox
    project root: .
--> token set from env
    Yaml not found, that's ok! Learn more at http://docs.codecov.io/docs/codecov-yaml
==> Running gcov in . (disable via -X gcov)
==> Searching for coverage reports in:
    + .
    -> Found 1 reports
==> Detecting git/mercurial file structure
==> Reading reports
    + ./coverage.xml bytes=1271
==> Appending adjustments
    -> No adjustments found
==> Gzipping contents
        4.0K    /tmp/codecov.WANzoc.gz
==> Uploading reports
    url: https://codecov.io
    query: branch=main&commit=ec4370f9552fffc4a615d5dc898da25a29f29407&build=&build_url=&name=&tag=&slug=aahnik%2Fpyproject&service=&flags=&pr=&job=&cmd_args=
->  Pinging Codecov
->  Uploading to
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   602    0     0  100   602      0   1076 --:--:-- --:--:-- --:--:--  1075
    -> Reports have been successfully queued for processing at https://codecov.io/github/aahnik/pyproject/commit/ec4370f9552fffc4a615d5dc898da25a29f29407

but after clicking on the link, it shows

inside github actions it passed, but clicking on the link gives unable to find report.

@aahnik, this should have been a blip on our side that was resolved today.